My mouse is stuck in "drag" mode. This generally happens in Photoshop, but happens dragging files and such as well.

Clicking rapidly here and there generally solves the problem. Sometimes though, it won't go away until a restart. Unplugging devices, etc., doesn't do anything.

For example, right now, my mouse moves but can not click anything so I am using the keyboard to navigate this site.

Is there a way to "reset" however the OS stores mouse states?

Can I manually fire off a MouseUp event?

It's strange that even when human input devices are unplugged, the files are still in drag state.

  • For the record, this appears to have been a problem with my graphics card and or OSX starting to crash. The problem got progressively worse until my computer would consistently crash. I'm still curious about manually sending a mouse up event though... – Yuji Tomita Dec 28 '11 at 5:02
  • superuser.com/a/13707/2084 contains code to simulate mouse-click events – dbr Nov 23 '12 at 22:26
  • I'm in 10.8 Mountain Lion. In some oddball apps I lose the ability to place the insertion bar and regain it by using Ctrl-Left then Ctrl-Right to visit Dashboard. Maybe that would work for this problem in Lion? – minopret Dec 21 '12 at 3:50

I got exactly the same issue, but the internet resolves nothing. It seems that when I restart my MacbookPro, it "could" go away. When I close all my apps, I get more successful results. When Lion loads the apps that were open when I restarted, I get a "sticky" drop scenario more consistently. Not hardware related, think it could be a Lion glitch.

Update: https://discussions.apple.com/thread/3191768?start=0&tstart=0

Quick fix for the drag and drop: sleep and wake your MacBook. For whatever reason everything is fixed when I do it. But if I restart, I lose it again. It must be some type of startup issue.

| improve this answer | |
  • I appreciate the "answer" but this would be more appropriate as a comment. If there's a solution in here somewhere, you can post that! – Yuji Tomita Apr 9 '12 at 19:36
  • For the record, on my part I get the glitch occasionally now, but not consistently as before. I know it has nothing to do with the hardware itself, as I plugged in 3 other Wacom Intuos 4 tablets with the same issue immediately manifesting. – Yuji Tomita Apr 9 '12 at 19:38

If you go into "Trackpad" in "System Settings" and toggle various options for gestures, clicks, and drags.. it will "unlock". Annoying, yes. Requiring a restart, no.

Also, sometimes a key on the keyboard gets stuck. Bang on the keys (or equivalent) to make sure that's not causing your grief.

| improve this answer | |
  • I will give that a shot next time it happens. If this is true, that would be a great find! – Yuji Tomita Jun 16 '12 at 17:20
  • Thanks! Turning on and off three finger drag worked for me. – ESRogs Jul 30 '13 at 12:21

I experienced this problem and dealt with it for a month or two by putting the machine to sleep every time I noticed it. This is only a temporary fix, however, as the problem returns on a restart. Not usually a problem, but makes apps like Photoshop neigh unusable!

I was pretty sure Air Display (an iOS screen sharing app) was the culprit so I tried uninstalling it with AppCleaner, but the problem remained. However, this SwitchingtoMac ad confirmed my suspicion: http://www.switchingtomac.com/tutorials/osx/cant-drag-and-drop-in-os-x-lion/

A quick Finder search turned up a proper uninstall script for AirDisplay and the problem was gone. The above article outlines a number of other possible solutions as well. Good luck!

| improve this answer | |
  • Air Display seems to been the cause of my issue as well. – Eric Holmes Oct 21 '13 at 22:30

I have the same problem from time to time. When it does occur it stands to reason that a system reboot should fix the problem and it typically does.

However, a 100%-sure-fire way to at least free up the mouse to make it usable without playing with settings or rebooting is to just FORCE QUIT which ever application the stuck icon originates from. If the issue is with an icon from the desktop then Force Quit (which is actually just Relaunching) Finder.

Although this won't fix the problem in that if you attempt to click and drag again, the object in question is basically guaranteed to get stuck again. It's a temporary fix that's faster than a reboot and sure to work every time.

| improve this answer | |

Have you checked if this is caused by Mouse Keys? This didn't solve this issue for me, but it worked for the poster there.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.