I'm trying to install the nppColdFusion plugin that enables ColdFusion syntax highlighting in Notepad++.

It installed easily on my home computer (Windows Vista, using Notepad++ version 5.8.6). However, when I tried to install it on my work computer (Windows XP, using Notepad++ version I get errors.

Running the installer provided (Install-nppCF.zip) failed, and when I tried to install all the files manually, it seemed to work but as soon as I clicked the "ColdFusion" language option in Notepad++ or opened a file with a ColdFusion extension, it crashed Notepad++. Any ideas?

  • I am going to guess the problem is connected to the fact the plugin does not support the newer version of Notepad++ I would verify this fact by installing the same version on both computers – Ramhound Dec 5 '11 at 16:14
  • @Ramhound - nope, that doesn't seem to be it. I tried reverting my work Notepad++ to a previous version and it still doesn't work – stuck Dec 5 '11 at 16:35
  • And now I updated my home version to the newest version, so they're both, and it's still working there... – stuck Dec 5 '11 at 16:37
  • The .ZIP file shouldn't "fail", as it's not an installer, just compression. If it does fail to open, then the .ZIP file is probably corrupted and you should re-download it. Which version of the nppColdFusion plug-in are you trying to use? Have you got the prerequisite sqlLite library/DLL installed/working on the work computer? – Ƭᴇcʜιᴇ007 Dec 5 '11 at 17:26
  • @techie007 - I meant the executable file that's extracted from that zip file. It's supposed to take care of downloading the sqlLite dll for you. Worked on the home computer – stuck Dec 5 '11 at 19:25

Author of nppColdFusion here.

Generally this has been down to putting the database and config file in the Program Files\Notepad++\plugins\config folder rather than the %appdata%\Notepad++\plugins\config

Alternatively Plugin Manager 1.0.5 supports doing the full install. (I haven't tried it though).

Interesting that the Install-nppCF script did not work, I have tested it on XP, however as it's your work PC, maybe there's some restrictions stopping it.


| improve this answer | |

I was having the same problem with the installation of the "Compare" plugin. The only thing worked, was removing all other plugins, so I am guessing one of the other plug-ins was the culprit.

I am guessing one of the 3 plugins I installed prior to installing "Compare" plugin, was the culprit. I only installed "Combine", "Column sorting" and "Customize Toolbar" before this issue surfaced but I checked and uninstalled all at the same time. My money is on either Column sorting or Customize Toolbar.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.