How can I set the default network connection to be Ethernet.

It seems my wireless card in my new laptop becomes active before the Ethernet and leaves me with that connection which is much slower than the Ethernet.

I then manually disconnect the wireless daily, however I would like this to happen automatically if possible.


1 Answer 1


You should be able to adjust the metric setting for each interface, giving preference to the wired interface. By default, wired interfaces with a faster link speed should be given preference using the automatic metric setting. However, according to TechNet, automatic metric is usually enabled by default.

  1. Right-click a network interface, and then click Properties.
  2. Click Internet Protocol (TCP/IP), and then click Properties.
  3. On the General tab, click Advanced.
  4. To specify a metric, on the IP Settings tab, click to clear the Automatic metric check box, and then enter the metric that you want in the Interface Metric field.

(steps above adapted from KB299540)

A lower number represents a preferred interface, since the number represents a cost value for selecting that interface.

  • I put the Ethernet as 1 and the Wireless as 2. Nothing changed immediately, I'll try rebooting. Commented Dec 6, 2011 at 0:53
  • I rebooted with Ethernet plugged in and according to the network icon in my tray i'm still on wireless. Is there a better way to tell which connection is being used? Occurred to me that the wrong icon might just be displayed. Commented Dec 6, 2011 at 0:58
  • Check your routing table - route print. Look for the route with the lowest metric, and the interface column will tell you the IP address of the interface it is using.
    – Paul
    Commented Dec 6, 2011 at 1:09
  • wireless 4 Commented Dec 6, 2011 at 2:14
  • ethernet 2 Commented Dec 6, 2011 at 2:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .