I have a new Dell XPS 17 laptop. My issue: The two USB 3.0 (SuperSpeed) ports on the rear of the machine are not recognising anything when I start up. I've tried attaching a mouse, keyboard, headset, and a USB display.

If I plug a USB hub in the power light on the hub lights (presume this is hard-wired) but a mouse plugged into the hub does not light up.

If I restart the pc the ports work fine. Also the other two USB ports work fine all the time.

I have switched off the power saving setting on the device manager (Power management>Allow the computer to turn off this device to save power) and also in the advanced power settings (USB Settings> USB Selective suspend setting:disabled)

I have also disabled USB powershare in the BIOS (not sure what this actually does!)

This is becoming very annoying having to restart the machine every day before I can start work

Running Win 7 Pro x64

I have found that setting USB Emulation to Disabled has helped the devices to be recognised during start up but they keep dropping out completely when in use.

I contacted Dell about this issue who told me to update the BIOS driver, when I asked if I should downgrade from the factory installed A13 to the A12 posted on the dell website they said no. However there is now an A14 available on the website has anyone tried this?

  • As it's new i would suggest RMA'ing it or taking it back where you got it from as it sounds like a voltage fault/short on those rear ports. – HaydnWVN Dec 6 '11 at 12:28
  • Update the bios if there is a newer version available from Dell – Moab Dec 6 '11 at 19:49
  • @Moab - I downloaded the bios file but when I tried to install it said the file was older than my current bios – Matt Wilko Dec 7 '11 at 11:01
  • @Matt what is the full model number of your Dell – Moab Dec 7 '11 at 17:43
  • @Moab - It is XPS 17 (L702X) – Matt Wilko Dec 8 '11 at 8:53

I had this same issue, my solution was to go Dell.com and the drivers section.

I downloaded the newest BIOS for my motherboard (I'm on XPS L702X) and the newest Renesas USB 3.0 Host controller, and once I installed both of those, the problem went away.

The Renesas driver is the one I think fixed it, and the download of it was named R317222.exe from Dell.com.

  • I installed this update but it caused by usb graphics cards to be really slow then opening up any window – Matt Wilko Jan 6 '12 at 9:28

If the posts above didn't fix your problems, it's probably your power supply/motherboard, so try this:

I just contacted Dell service about the same USB 3.0 issue you're talking about. They told me that a lot of those XPS 17 702x PCs that were ordered after June 2011 have a motherboard and powersupply that just can not redirect enough power to the USB ports for them to work properly. The day after I contacted them, a Dell Service Person contacted, showed up at my house and replaced both the USB 3.0 ports and installed a whole new power supply/motherboard. This happened about a week ago and I use my XPS 17 both at work and on a private basis very frequently, and haven't had any problems with my USB ports since. :)

So my advice is to contact Dell for a replacement parts. :)


My rear SS USB ports would stop responding to anything I plugged into them, though they still seemed to show power output. I went to Dell's website and entered R317222.exe in their website's search bar and followed the instructions to install the new driver for the Renesas USB 3.0 Host controller.


I have an XPS 12 that wasn't getting enough power to both USB ports. Then I upgraded the bios from 5 to 8 and viola! That fixed the issue. My issue was with a Logitech unifying remote that wouldn't work well at all unless I connected the unifying receiver to a powered hub. But now I finally don't need that powered hub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.