17

I have limited screen place, and I'd like to know how I could remove the title bar.

I use hotkey to close, maximize, etc. anyway.

  • 1
    If I were you, I'd consider selecting another answer as the accepted answer, or at least unaccept the one you've currently selected... – Aaron Hall Jan 10 '18 at 4:58
4

Edit 2018-01-31: Please note that a 4-years-later/now-higher-voted answer notes a built-in XFCE setting now available, which is probably a better option for many.

Try the maximus package? Here's the package description:

A desktop daemon which will automatically maximise and, optionally, un-decorate windows. Has support for exclusion lists and will work with any EWMH-spec compliant window-manager.

Install with:

sudo apt-get install maximus

I believe you'll need to add the maximus command to your startup programs, as it does not automatically run at boot on its own.

There's also this idea, to integrate title bar stuff into the top panel: http://xflinux.blogspot.com/2011/01/maximise-vertical-space-in-xfcexubuntu.html

  • +1. To configure maximus, one can use gconf-editor. To blacklist windows, add the class name returned by xprop | grep CLASS to the exclude_class parameter (further reading). – ignis Jan 4 '13 at 4:15
  • 4
    That link appears to be dead. – Enigma Jan 12 '15 at 20:10
  • I've downvoted this because the functionality appears to now be built-in to XFCE (as another answer tells us) making this a suboptimal answer. If it weren't pinned to the top, I probably wouldn't bother downvoting or writing this. – Aaron Hall Jan 10 '18 at 17:51
  • @AaronHall that seems fair enough. My answer was relevant when posted more than 6 years ago, so it's no surprise that XFCE has grown some new settings in that time ;-) I'm not sure how down-voting impacts my SO reputation or anything. It seems a more sensible move would be for an admin or Galadude to mark the newer/higher voted response as the accepted best answer now. I'll also throw a little update edit in my answer... – Jamie Krug Jan 31 '18 at 16:59
  • @JamieKrug given that Galadude seems rather inactive, and since Stack Overflow never unpins accepteds (unless they're self answers), updating your answer to reflect the new information is the right thing to do. Ideally everyone would curate their answers and keep them up to date, but that would be an unrealistic expectation for most people. Even I only curate answers I get updates on anyways... – Aaron Hall Jan 31 '18 at 17:39
22

Recent versions of XFCE have this built-in. Check out Settings Manager > Window Manager Tweaks > Accessibility > Hide title of windows when maximized.

Maximized windows will not have the title bar then, while non-maximized windows will have it. Tested on ArchLinux, xfce version 4.12.0-4.

  • I like this - but to unmaximize, minimize, or close I suppose I have to do Alt-Space or right click the program in the, uh, main panel? (I suppose for close I can also Alt-F4 it...) – Aaron Hall Jan 10 '18 at 4:55
  • @AaronHall You are right. Since there is no "close" button visible, you have to do it somehow else. – VasyaNovikov Jan 10 '18 at 9:27
  • Are there panel plugins that add close/restore/minimize buttons? Absence of those in the panel when there is no title bar is definitely design lack. – 4xy Sep 2 '18 at 21:28
  • @4xy I don't know any such panel items. Could be nice to have them, but none present ATM. – VasyaNovikov Sep 3 '18 at 7:49
5

I had the same issue with the titlebar and I solved it to a good level this way:

  • Settings > Settings Manager > Window Manager > Theme tab > Kokodi (it has a high titlebar)
  • Settings > Settings Manager > Panel > Row Size (pixels) = 28
  • Settings > Settings Manager > Panel > Don't reserve space on borders = Yes, turned on

This way, the titlebar is just hidden below the panel. Benefits of such approach:

  • The titlebar remains visible for small windows
  • The titlebar is autohidden with Alt+F10 (but the panel remains visible in all cases except hard fullscreen Alt + F11)
  • If you have "snap to other windows" enabled in your window manager, you can easily get an almost-fullscreen window, with panel and titlebar still visible. Just start to change window size and it'll do a stop in the point where panel starts (allowing to go further though).

The bad thing is that it feels like a hack. I searched this topic because I wanted to find an xfce setting for this (failed yet).

  • A easier way is to adjust the panel height until it fits - Nice approach, thanks :D – Wilf Jul 30 '14 at 17:15
  • 1
    Additional note, you can set this with this command: xfconf-query -c xfce4-panel -p /panels/panel-1/disable-struts -s "true" - just change the true/false (the panel-number may also need to be changed) – Wilf Jul 30 '14 at 17:22
  • Don't reserve space on borders is what I wanted! – nmz787 Dec 29 '14 at 9:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.