2

This is an interesting conundrum where all the normal solutions don't work.

Yesterday, I downloaded several movie clips with a wmv and avi file extension when booted in Ubuntu after hibernating my Win7 installation. I use a NTFS-formatted partition to store common files for independent OS usage, and this is where the clips were downloaded. While the videos were downloading, I watched one via streaming the .part file extension to VLC. The video came through fine and I had no issues with it.

Today I tried to load up the second one, and I kept getting stream unresolved errors. After a look at the file sizes, I saw that one was 46KB and the second was 336KB, when the real sizes should bee 480MB and 1.2 GB, respectively. These files just won't delete.

Here's what I've tried so far

  • rm -f FILE.wmv
  • rm -i ./FILE.wmv
  • mv FILE.wmv File2.wmv

In all cases, I've had the error cannot remove file: no such file or directory found

However, a ls -l check shows that the files DO exist and the appropriate read/write permissions are set.

Any solutions come to mind?

3

If Windows has access to an NTFS partition (ie it is mounted), and is hibernated, it will assume that the partition is unaltered when it comes out of hibernation - it will carry on where it left off. Same with linux in the other direction.

So if you boot linux after hibernating windows, alter the contents of the partition, and then resume Windows, this will almost certainly lead to corrupt files.

While you can fix this with ntfsfix on linux, or chkdsk on Windows, you will end up losing data.

|improve this answer|||||
0

Try checking your NTFS partition.

You can use ntfsfix (part of the ntfs-3g suite).

|improve this answer|||||
0

Did you try a sudo rm? I have had strange permission based issues when accessing a non-ext4 partition on my own system (I quad-boot Win7, WinXP, Ubuntu Studio, and Linux Mint), and in quite a few cases running a rm, mv or cp command with sudo allowed me to fix the issue.

And before anyone down votes for relevance let me say I only mention this because I have gotten the "file not found" error when interacting with a perfectly healthy Windows partition in Linux.

Hope that helps...

|improve this answer|||||
0

Files/folders transferred to a Unix / Linux account from a PC or Macintosh having names containing what Unix (Linux &c) considers to be a meta-character all too often cause problems like this.

Meta-characters (e.g., dashes, slashes, semicolons, spaces, dollar signs, question-/exclamation-marks and asterisks) are interpreted under Unix as commands or instructions. Tho' these characters may not cause trouble in other operating systems, their special C/C++ interpretations can cause issues in Unix and Linux operating systems.

Some techniques for deleting strange files and folders:

• Try the rm command whilst enclosing the troublesome filename in quotes.
This may solve the problem of deleting files w/ spaces in their name, for example:
rm "File Name"

Some other special characters become deletable in this way, for example:

rm "filename;#" ==> The quotes prevent the semicolon from being interpreted as a stacking command; commands are strung together via semicolons, so unless a semicolon is put in quotation marks, Unix and Linux machines' C language interprets it as a stack-command, thereby rendering the file itself as invisible.

• Also viable, renaming the troublesome file or folder, whilst placing quotation marks around the original filename, for example:
mv "filename;#" new_filename
 If this command successfully renames the file, then use the rm command to delete the file now newly named using that new name for it.

• If these methods don't work, insert a backslash ( \ ) before the meta-character in the filename. The backslash causes the character that follows to be interpreted literally. For example, to remove the file named my$pecial-folder, enter:
rm my\$pecial-folder

• To remove a file whose name begins with the dash (-) character, refer to the file with the following syntax:
rm ./-filename
 Using the redundant ./ directory information prevents the dash mark from occurring at the filename's beginning, which would otherwise be interpreted as an option of the rm command.

• There are some characters that cannot be removed using any of the above methods, such as forward-slashes, interpreted by C/C++ as directory- separators. To delete a file containing such meta-characters, FTP into the account containing the file to be deleted from a separate account, then enter the command:
mdel

Answer n (for no) for each file — except for the file having the troublesome character desired to be deleted: Delete that file by typing y (for yes) when prompted. After the difficult file has been removed, press: Ctrl-c to discontinue the mdel process.

• A telnet session along with a graphical FTP client can also be used to remotely log into an account, and then a troublesome file can be deleted simply like the deletion of any normal file.

• Some Emacs editors allow for the direct-editing of a directory; another removal method for files which possessed a paranormal character.

///

As for the “.\” (dot-backslash), it's used to log onto a Windows machine.

The period-symbol is the shorthand for "this machine"
and the backslash-symbol serves as a separator (aka delimiter ) between hostname & username
when using the [host]{backslash}[user] style of authentication against a Windows machine; i.e., the .\ stands for
anglebracket this computer anglebracet backslash anglebracket user name anglebracket

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.