10

I have a desktop/laptop pair at home operating x64 Windows 7 (the desktop was upgraded from Windows Vista, works just fine). I remote desktop to them on a daily basis when outside.

In recent weeks, I would occasionally fail to connect to my desktop. It can connect and authenticate fine, but the "configuring remote session" dialog would simply close and not show me the desktop window or any error message.

There is no error event log relating to this on the desktop computer.

Some suggestions call for disabling remote audio, which mine already is, but trying different audio modes did not yield any different result.

I am not too sure if this is related to video card drivers (they do get auto-updated), since remote desktop video is supposed to steer via a virtual device driver? Nonetheless the desktop operates three monitors via an ATI Radeon HD5770 (1 Displayport, 2 DVI). I do not see a real problem with that since I can mostly connect and operate it remotely.

I try to "remote tunnel" via my home laptop but obviously won't work either as the problem lies in the desktop. What other conditions can cause remote desktop to break without error?

UPDATE I came home and still couldn't connect to the desktop until I restarted the entire system.

  • 2
    I had this problem with a server in Amazon Web Services, EC2, we rebooted it, and it took forever installing updates, like, genuinely, a solid hour. It was a t2 burstable that ran out of credits, so it was grinding super slowly. To see if this is your problem you can "Get Instance Screenshot" by right-clicking the instance in the EC2 console. – turiyag Jun 2 '17 at 15:05
  • 1
    @turiyag, thank you, thank you, thank you. I did just install updates and figured it was an updating/reboot issue but did not know about the "Get Instance Screenshot". "Working on updates 77% complete Don't turn off your computer". – Andrew Steitz Oct 26 '17 at 17:56
8

I started having a similar problem out of the blue on a PC at work--it connected and just hung there at the 'configuring remote session' window.

I found that I needed to go into the options under the 'Experience' tab and de-select the Persistent Bitmap Caching setting.

Once I disabled that setting I was able to connect quickly as expected.

| improve this answer | |
  • 1
    It didn't help me... :-( – itsho Jun 14 '15 at 13:11
  • de-select the Persistent Bitmap Caching setting did the trick for me thank you – Sun Aug 31 '15 at 1:36
  • A suggestion; if this is the issue, perhaps there's some corrupt file cached, rather than the feature itself causing the issue. In that scenario, try deleting your machine's RDP cache (i.e. folder %localappdata%\Microsoft\Terminal Server Client\Cache), reboot (not sure if needed; but always good to keep things clean), then try connecting again. – JohnLBevan Jan 17 '18 at 14:28
1

Cannot remember when but I guess one of those eventual Windows updates patched this problem.

| improve this answer | |
0

Other forum

Seems you're not the only one facing something like that.

Unless you're using sound for your remote I would suggest to try and disable Remote Audio. Maybe a bug in Windows 7 (nothing to do with clean or upgrade).

Check this out

| improve this answer | |
  • yes, i am not using audio. any audio setting won't fix the problem anyway, until a reboot. – icelava Dec 12 '11 at 3:54
0

This can also happen if you have initiated a large Windows Update that is not yet fully configured or if the computer is not yet fully restarted. You can not remote to the desktop but the IIS might still receive and return responses for example. In this case all you need to do is wait.

A good thing to try is also deleting %localappdata%\Microsoft\Terminal Server Client\Cache and restarting your computer as mentioned by @JohnLBevan in comments.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.