With Windows XP and Windows Vista, I try to remove an external USB hard drive, but usually get the message ""Windows can't stop your 'Generic volume' device because a program is still using it.". I tried closing all programs on the desktop, but it still won't give the "safe to remove" message.

I am generally able to make flash drives safe to remove without a problem.

  • 5
    Sleep the box, remove the drive once the box is asleep. – Daniel R Hicks Apr 11 '14 at 11:44
  • 1
    Still a daily problem on Windows 10 Pro (1703, 15063.413, x64). – Tamás Bolvári Sep 16 '17 at 23:56

17 Answers 17

up vote 22 down vote accepted

Look for RemoveDrive on this page (direct link to the Drive Tools page RemoveDrive tool section).
Those pages also have good related information.

The RemoveDrive tool is useful also when
you Do not get ‘Safely remove’ option in Tray for USB storage devices.

  • Anything that can tell you what is holding the drive is good. I've gotten this after I closed everything, all explorer windows even. So sometimes Windows just doesn't want to let the drive go. – Joshua Nurczyk Sep 6 '09 at 18:21
  • @Joshua, I have felt that sometimes Windows is Indexing the drive and holds it for that... The "-i" option on RemoveDrive disables the indexing service for a moment to remove the drive. – nik Sep 6 '09 at 18:22
  • I like Unlocker which is dedicated to the task of displaying and freeing open file/directory handles. – opello Sep 6 '09 at 18:24
  • 1
    Re unlocker: Note that this is dangerous. You will be able to remove your pen drive but you risk corrupting future files when a file handle gets recycled and both the new and the old program try to write data to it. – Hennes Aug 15 '14 at 21:39
  • 1
    Relevant article on technet which talks about closing file handles for deletion, but the same holds in the pendrive case. – Hennes Aug 15 '14 at 21:50

Often this will be because the drive is being indexed; right click the drive>properties, and uncheck index. Or the AV is monitoring the drive - turn off AV to test this.

There are several reasons to USB being undismountable:

  1. It's in use. Please note that if you're looking at the disk in Explorer, then it's in use!
  2. Windows is finishing copying a big file to or from the disk (rarely the reason)
  3. A bug in Windows causes conime.exe to get stuck on the disk (it may safely be killed)
  4. If the USB drive is formatted as NTFS, the journal of all file updates may still be open
  5. If disk indexing is on for the drive, Windows may be furiously indexing all files on it

My advice is to:

  1. Make sure the USB drive is not defined as indexed.
  2. Wait, and then try again. It might work a few seconds later on.
  3. Buy Zentimo ($29.90) that does a good job of trying to remove the disk. Even if it fails, it still tells you which programs are using what files (I paid).
  • would deleteting a large amount of data cause this problem? I deleted about 1TB of data, and it looks like the process completed, but the drive will not eject safely. – SoilSciGuy Oct 2 '15 at 18:00
  • @SoilSciGuy: If none of the above points works for you, use the free Process Explorer to search for "X:" (X=disk) to see if it's being used. – harrymc Oct 2 '15 at 19:05

I found the free USB Disk Ejector to be very useful:

A program that allows you to quickly remove drives in Windows. It can eject USB disks, Firewire disks and memory cards. It is a quick, flexible, portable alternative to using Windows’ “Safely Remove Hardware” dialog.

  • Looks like a great app, but did not work for me. – RockPaperLizard Jul 20 '16 at 21:15

This is by no means a good answer, but you can always shut down the computer and remove the USB device.

  • 1
    Actually you can't! You'll hear the drive click. But if it's ejected the click doesn't happen. I don't know if that matters, but I've had problems with two external hard-drives (drive appeared unformatted), I suspect it was because of such shutdowns... – Alex Oct 9 '13 at 2:24
  • @Alex If you shut a computer down, it can't be using a drive if it doesn't have any power. – starbeamrainbowlabs Nov 2 '14 at 14:49
  • Shutting down the system was my solution until chkdsk started finding errors after doing that. – RockPaperLizard Jul 20 '16 at 21:17
  • 1
    @RockPaperLizard Then there's something wrong with the software. The OS told the program that it's shutting down, it still didn't flush writes and close the file. There's nothing you can do at that point besides smack the developer on the head. – dtgq Jan 7 '17 at 16:20

If it's none of the pedestrian/common options, it could be you have the drive listed as 'shared' on a network and have accessed it via another computer. In my case, even though the remote computer was off, it still had a lock on the directories. Unshare and it should work if that's the case.

  • Right click on the properties of the USB drive in Windows Explorer.
  • In the popup window click on "Hardware".
  • Identify the drive and left click on it once to highlight it, then click the properties box.
  • Click on "Change settings".
  • Click on the Policies tab and select "Optimize for quick removal" and click OK.

If you're sure that none of your own processes are still in use on this USB just pull it out.

[Edit: Not found official Microsoft documentation of this method, but Cnet has an article about it: Quickly remove USB devices without using Safe Removal .]

  • This method is so much better than all the rigamarole of the higher-rated answers. – NewSites Jan 25 at 4:23

Quick Way to Find Process/File Open that is Preventing Unmount:

I just figured this out. With Process Explorer (free download) this is really easy.

  1. Download, unzip and run procexp.exe
  2. Choose from the "Find" menu, "Find Handle or DLL..." or hit Cntl-F
  3. Enter only the drive letter (followed by ":\") in the search text box

This will show you all the open files on your removable volume, the processes that own the file handle and the PIDs of the processes. Double click to highlight the process in the main window (top) and file (bottom). From there you can right-click the process to kill it or right-click the file to close the file handle.

  • 1
    Upvoted because this tip was pretty cool. Unfortunately, I'm still stuck. I found that explorer.exe was the culprit. I restarted explorer.exe and then did the search again, which resulted in "0 matching items". But I still get the error message "Windows is unable to stop the device...". – Ryan Jan 7 '17 at 15:40
  • 1
    In my case it says that only "System" is holding the reference. – TN. Jan 1 at 22:47

I think this is because Windows itself is still finalising the writes to the hard drive. I get the same message if I try to disconnect straight after copying some files. If I wait until the drive has stopped spinning then it disconnects without any problem.

I haven't been able to find any information on why this is, so if someone could enlighten us I'd appreciate it.

Take a look for programs installed recently, which can prevent safe HDD disconnection.

In my case it was Magical Defrag 2: any newly connected disk with new letter assigned was automatically marked, so now after unmark I can safely remove the USB drive.

Simple fix (Windows 7 Professional 64-bit):

  1. Change the drive letter, and if you want to keep the same letter, change it back.

  2. The drive can now be unmounted.

When you change the drive letter, it disconnects the drive from all processes that might be using it, as the warning message states. Once that happens, you can then unmount it the usual way.

If you don't know how to change drive letter, follow these instructions.

  1. Control Panel --> Administrative Tools --> Computer Management --> Storage --> Disk Management (wait ~10 seconds for information to appear.)

  2. Select the problem drive under volume heading.

  3. Scroll to that drive in the lower part of window.

  4. Right-click on the drive, and select Change Drive Letter and Paths.

  5. Change the drive letter to one not reserved for another drive.

  6. Acknowledge the warning message.

If you wish the drive to retain the original letter, simply switch it back. The drive can now be unmounted.

  • Just so you know, that particular answer has been cited on a blog post : cybertext.wordpress.com/2017/02/22/… – for that reason alone it deserves an up vote. But unfortunately, I just tested this method with a stubbornly locked USB HDD, it doesn't work when the “System” process is the culprit (I get this regularly, and neither ProcessExplorer nor LockHunter can close the handles associated with four system files in \$Extend\$RmMetadata\, and changing the drive's letter results in the same handles reappearing just a second later with the new letter). – GabrielB Dec 7 '17 at 14:58

The 2 most reliable ways are ones that nobody has suggested yet because they are sometimes the most inconvenient:

  1. Log off. Log back on. Try again to safely eject the USB device (via the Windows tool). If even that didn't work, then:
  2. Shut down your computer entirely. Then simply unplug the USB device without asking permission.

This is due to the fact that there is at least a process/program that is still accessing your USB drive. It may not be enough if you just close all the programs on dekstop, if you are copying folders from/to the USB hard disk, you will get this message.

Try and find what process is holding the resource and either complete or close the process and you should be able to remove the USB hard disk without any problems.

Do let us know how it goes.

I've noticed this a lot. What we do is to share and then unshare the drive. It's had a 99% success rate. I have no clue why it works, but time to time it says another user is accessing the drive... even though I just shared it only to unshare it. Try that. You'd be surprised at the success rate.

  • This tip unfortunately hasn't worked for me with my external Backblaze hard drive on Windows 10. – Ryan Jan 7 '17 at 15:44

For me changing the drive letter did it. I could not kill the accessing process cause it was PID 4 (system itself), which opened H:\$EXTEND..... (did see it in Process Explorer).

After changing the drive letter i could savely remove it..... WOW, Windows is a never ending adventure game..... :))))

this method worked to me 1) : Run -> "diskmgmt.msc" -> Find your drive in the physical disk list (bottom pane) -> right-click the drive (the left-most part), not the partition -> Click "Offline"

2) : Run -> "cmd.exe" -> type "diskpart" -> type "list disk", find your disk # -> type "select disk x", where x is your disk's # from the last step -> type "offline disk". Now you can exit the command prompt or just type "exit" at diskpart, then close the prompt."

I use "remove all dismount" on the diskpart command to kick the disk out. can't make it simpler now as Devcon command couldn't kill the disk out soon either.

now use the safely remove hardware and eject media tool

Thanks to

Reizaal Abdul Aziz

https://answers.microsoft.com/en-us/profile/bf1a3358-a39a-4c32-bc7e-692576439363

  • Welcome to Super User. It looks like you are trying to provide attribution. Just "advertising" a stranger isn't a useful way to do that. Instead, link to the source of the information. – fixer1234 Feb 12 at 0:38

Try hotswap free utility, you can download here http://mt-naka.com/hotswap/index_enu.htm.

  • Ensure to activate Safely removable devices by right click the icon hotswap on systray - device type - Safely removable devices.
  • Then you can remove USB drive by left click icon hotswap on systray and select your removable drive.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.