3

Pressing Ctrl+Shift+I in Windows 7 results in a Tab character being inserted, regardless of the application. Since it conflicts with the default "Inspect" key binding in Eclipse, I would like to remove it. Is it possible?

5
  • Just executed CTRL + SHIFT + I within VS2010/Win7 and was met with the active application's key binding, which is not a Tab char being inserted. Key shortcuts work off the active window and then move upstream if not handled. Commented Dec 13, 2011 at 22:09
  • Indeed, the Tab character is not always inserted. In Notepad++, Sticky Notes, Eclipse it is inserted, but in Firefox, Chrome, IE, Skype it does not. This is not the first Eclipse installation where I have this problem. Ctrl+Shift+I has always worked for me in Windows XP, that's why I assumed that Windows 7 was to blame. Can I change this tab-inserting behavior somewhere in the Windows settings? Commented Dec 13, 2011 at 22:22
  • I can't get Ctrl+Shift+I to print a tab character in any application. Do you have a third-party keyboard filter or hotkey program running? Commented Dec 13, 2011 at 22:22
  • I'll check, maybe this is some Lenovo/Thinkpad thing. Is there a place where I can see things like this (e.g., the registry, Process Explorer)? Commented Dec 13, 2011 at 22:24
  • Looks like the "Inspect" keybinding in Eclipse is not working. I tried changing it, resetting to default, I still can't initiate an inspect from the keyboard. It works with the right-click menu though. Commented Dec 14, 2011 at 19:44

2 Answers 2

1

First, I am typing this with Windows 7 Enterprise SP1 64-bit.

Next, CTRL+SHIFT+I is not listed as a keyboard shortcut for Windows (that KB applies to Windows 7).

So I tested it out in Notepad. Sure enough, CTRL+SHIFT+I inserted a tab. I came back to Chrome and tried it. On most pages CTRL+SHIFT+I bring up the development tools. In this very text box, it italicized my text.

Odd. CTRL+I is a standard italicizing short cut. So I tried CTRL+I, and sure enough italics (good work Stack Exchange Team!). Back in the rest of Chrome, CTRL+I appears to do nothing. Back in notepad, CTRL+I inserts a tab.

Interesting. Other places to try CTRL+SHIFT+I: The Run dialog (Start -> Run, or Win+R). Nothing. Windows Explorer (Win+E). Nothing as well.

Based on this I don't feel it's a case of Windows conflicting with Eclipse, rather I would suggest checking Eclipse to see if the key binding for CTRL+SHIFT+I is present.

2
  • Thanks, this is exactly what I observe. I checked Eclipse, but I will try again:) After all, I can use another binding, just was wondering if this was easily fixable. Commented Dec 13, 2011 at 22:27
  • I also have this annoying problem, but Eclipse doesn't have multiple bindings to this shortcut. Commented Oct 4, 2016 at 13:49
0

Ctrl+Shift+I , Ctrl+Shift+D only works in Debug perspective (Eclipse Neon), otherwise it falls back to some system default binding (TAB) or to nothing.

  • So if you don't like switching always the perspective for debugging (like me), use Debug perspective as your default.

  • Preferences -> Keys -> Restore Defaults migth also be helpful in some cases described here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .