I have a system running Windows7 with Intel's onboard SATA 'fake' RAID It's causing issues with some software so I'm trying to remove it.

I have the system imaged to an external drive, boot from CD and restore. But the resulting system won't boot and system repair can't fix it.

I've tried setting the SATA to both IDE and AHCI but nothing works.

Any ideas - I really don't want to reinstall from scratch !

edit: more detail

  1. Windows-7 Pro 64bit with motherboard raid

  2. Imaged 'c:' drive partition using windows backup "create system image" onto external drive

  3. un-raid drives, set to either IDE or AHCI

  4. Boot from Win7 install CD and select system image recovery

  5. Select image and do full restore - reformatting partitions

  6. It restores correctly, no errors

  7. On restart it briefly flashes a BSOD and reboots

  8. Running Windows repair on the partition says no errors fixed

  9. Opening the command prompt from the CD repair boot shows an apparently fully intact C: drive

migrated from serverfault.com Dec 14 '11 at 1:18

This question came from our site for system and network administrators.

  • - posted on superuser but didn't get any views. Since it's a work machine I thought I'd try serverfault – Martin Beckett Dec 14 '11 at 15:44

You needed to enable the AHCI driver mode before you imaged the drive. See KB article 922976 for the registry editor method. Unfortunately, the automatic restore can't fix it because the driver is installed, it's just not set to support AHCI mode.

If you have another controller on your motherboard, the following method may work:

1) Connect the drive to the other controller.

2) Do a startup repair.

3) Connect a spare drive to the main controller.

4) Boot and let Windows configure the main controller so the spare drive works.

5) Shut down.

6) Remove the spare drive. Connect the main drive to the main controller.

7) Reboot. Do a startup repair if necessary.

  • I can't enable AHCI before I image the drive because the boot drive is part of the raid set. The restored image has the MSAHCI set in the registry, but as you said - no driver. Looks like it's re-install time! – Martin Beckett Dec 14 '11 at 0:27
  • You can enable AHCI before you image the driver. See the link. It just takes a registry change. (It only needs to be enabled in the driver.) – David Schwartz Dec 14 '11 at 1:42
  • Yes so long as I change it back before I reboot ! I did check it on the imaged copy but I guess i was reading a temp rescue registry hive rather than the one in the image. – Martin Beckett Dec 14 '11 at 2:19

Use the Microsoft deployment toolkit to capture the image and then redeploy. This will sysprep the system so pay attention to any apps that might need to get reinstalled. You can test that by deploying to a virtual system first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.