I have HP pavilion 2200 series laptop with AMD processor, 1GB RAM, on board nvidia display card. It suddenly cause following problem:

When the adapter is unplugged, the touchpad works correctly and smoothly. But as soon as it is connected, the cursor response badly but when i use external usb mouse, It works fine.

I have check somewhat same question here, It tell me that it is somewhat regarding power supply issue, but it is little different then this one.

I have my original adapter but few days before i have given it to vendor for service due to slow speed Blue Screen issue with OS.

Does anyone know that how to troubleshoot this????

  • 1
    Honestly, this sounds like a design flaw from HP. You should probably bring it to them.
    – TheCompWiz
    Dec 14, 2011 at 17:15
  • what is wrong in the question to down vote??? the behavior of hardware is different so i asked this.. if someone faced then explain little about this.. why this happen?? not every HP laptop have such problem i am this stuff since last 7 years.. Dec 14, 2011 at 17:29
  • @NiranjanKala: I'm guessing that this is some sort of grounding issue. If possible I would try different power outlets and / or a different power adapter. Also try moving the adapter further away from the laptop in case there is electromagnetic interference.
    – James P
    Dec 14, 2011 at 17:42
  • I just bought a new adaptor and had same problem. But only in my bedroom and not in living room. Then I realised my new adaptor is 3 pin, my old was 2 pin, so it IS a grounding issue. AND the reason it was working fine in my living room was because I was plugging the adaptor into a BELKIN surge protector, not the main plug socket. As soon as I did the same in my bedroom the problem went away. SO the simplest solution appears to be the cheapest and easiest. Just isolate the ground on the adaptor by plugging into a surge protector.
    – user214940
    Apr 7, 2013 at 15:25

13 Answers 13


Sometimes in windows when you plug the power in, it changes the battery/perfomance mode to MINIMAL PORTABLE/LAPTOP, check that it does not do that.

enter image description here

In Control Panel double click Power Options. Here you can set timeouts for your monitor, system standby, and hibernate. Notebook computer users can specify an alternative power scheme that will take effect when the PC is running on battery power.

Another problem can be the system driver, make sure you have the original HP driver installed.. Usually the mouse pad from HP use the Synaptics Drivers, and that should reflect in the device manager.

enter image description here

If the problem persists it is most likely going to be hardware related, by the sounds of things this is an old notebook, and could just have some fault components.. Sorry.

  • i will try this and let you know.. well thanks for response. Dec 14, 2011 at 17:40

Recently, I discovered touchpad malfunction (i.e. jumping, erratic, etc) in two of my laptops due to a power adapter. I checked the voltage with a multimeter, and it was in range. Also, I did the RF interference test explained in other posts, and found no interference caused by the power adapter.

Finally, I followed the pevious post to eliminate the capacitance charge touching the ground metal of the labtop, and the touchpad control improved a little. So I desided to have a better ground connection somewhere outside the laptop. I used a piece of thicker aluminum foil from a sealer of a ground coffe container. Then I managed to open one of the plastic covers at the bottom of the labtop, and secure the aluminum sheet with one screw inside the cover. Then I bend the aluminum sheet to have an exposed sueface outside. Finally, I secured the edges with etectric tape. This creates a permanent grouding surface that can be touched by hand or my lap.

I tested and it works great. The adapter does not afect the touchpad anymore. Just make sure the aluminum sheet only touches ground and no any other circutry connection.

  • could you please add a picture of it? ("secure the aluminum sheet with one screw inside the cover" + the final result)
    – JinSnow
    Feb 25, 2016 at 7:58

I have the same problem on a Sony Vaio VGN-FZ140E that I bought in June 2007. The touchpad was intermittently becoming very non-responsive and could barely track my finger. After reading the above posts, I realized that I too had recently replaced the power adapter with a cheapo ($10) one from Amazon. I unplugged it and - presto - no more touchpad problems. The adapter I got works fine in charging the battery, but I did notice that per the specifications written on the brick, it puts out about .8 more amps than the original. I don't know if that has anything to do with the problem, but it was something that caught my eye because the Amazon page said it was a replacement for my exact laptop model. I did some further testing to see why the problem was intermittent for me. It turns out that when I plug the new adapter into a short, ungrounded extension cord that I occasionally use, the touchpad problem goes away.


"Just isolate the ground on the adapter" Followed as above. Only difference I did was taped the Earth terminal with masking tape & "Voila" It worked.

  • 1
    "earth terminal", I'm not sure to understand what the "earth terminal means": you taped the the ground pin that goes to the wall outlet (which means it's not grounded anymore)? How does it work? (A picture of it would have been handy)
    – JinSnow
    Feb 25, 2016 at 8:09

It's a ground loop problem with Synaptics touchpad (Dell Inspiron 14 in my case), maybe related to a bad power supply. I'll edit this reply if other PSU fix the problem.

As some other people say, a fast workaround is to touch notebook ground: Make a couple of loops around power plug with a clip and touch it while using the touchpad. You can also use any USB cable, just plug it and touch the other end, the metal shield (grounded). You can buy or make a DIY anti-static grounding wrist strap connected to the notebook ground (USB or clip/power plug), like Roreru's answer.



This appears to be a common problem, especially with replacement adapters, judging by the number of posts on the net. However, no solutions seem available. I have recently encountered the same problem with some HP and Toshiba laptops which I bought. I had some genuine adapters but some were missing so I bought replacements on ebay. With most, when they were plugged in the touchpads were erratic and unusable. Running on batteries, everything was fine. As I could compare the situation with genuine adapters, it was easy to prove it was an adapter problem. A USB mouse worked fine even when the replacement adapters were plugged in. Interestingly, if a metal part of the laptop were touched, eg, VGA port, com port, USB port, then the touchpad worked rormally with the replacement adapters. It wasn't due to the earth pin on the adapter as some have suggested, as the original Toshiba adapters only have 2 pins and work fine. It must be due to the earthing of the laptop itself which in the original adapters probably occurs via the neutral pin. There are 2 work arounds. I have given up on the touchpads and am using a USB Mouse. You can also plug in a USB printer cable and tuck the other end into your underwear but that's hardly practical. If you buy a cheap replacement adapter off ebay, I suggest that more than likely you will still have the same problem. If you can get a genuine replacement (expensive?) then you should be OK. Cheers


I have an HP Pavilion g6 and I have the exact same issue. As others have mentioned it appears to be some sort of grounding issue. I am using the original HP power supply.

Issue: touch pad skips when plugged in.

Work arounds:

  • Touch metal on one of the connectors (like the USB port)
  • hold power supply in hand
  • Put laptop in lap.

There are tons of posts about this same issue from various laptop manufactures using Synaptics touch pads.


Solved for me:

Fujitsu Lifebook UH552 synaptics touchpad problem. When connected to the power supply the mouse response badly with the touchpad, but a external usb mouse works fine, but important only when charging, if the battery is full charged, the power supply makes no trouble, even it is connected. I had the same problem on two similar Lifebook's.

I connected an similar in "volt and amp" ASUS charger, and the problem was gone. So I don't know, the reason may be that the quality of products has too big a variation.

But all in all, two new quality power supply's for the Lifebook's was my solution.


I had this problem too, i have ASUS k55VM-SX102 laptop, 2.5yrs old, i bought a new adapter half a year ago (ASUS one, but higher power than original). Symptoms were the same, cursor was jumping like if it was crazy, but calmed down when i pulled adapter plug out of computer, put pc in my lap or touched other metallic parts of it. So i started unplugging everything in laptop's proximity: phone, wifi-router, lamps, everything. And I noticed that the issue was gone when i pulled out my ventilator (it's cable was lying on my adapter). As a guy who finished studied physics when i finished high school, this seems weird to me, but it works. I just have to move my fan cable to >30cm from adapter.


I'm late to the party, but tonight I began experiencing this same problem with my 3 year old Asus laptop. When plugged in the trackpad cursor would skip and flicker even if my finger was stationary on the pad. Unplugging and running on battery fixed the issue. After stumbling across this thread I decided the issue might be electrical interference from something else in my room. I immediately turned to the only new addition to my room - my brand new humidifier (shaped like R2D2 so cute). As soon as I unplugged that, my laptop went back to normal even when plugged in.

I fail at computers and all things electrical. I really do. But somehow this issue is being caused by plugging in new devices in the house. My laptop and the humidifier are plugged in on opposite sides of the room and in separate outlets. I don't understand how they're affecting each other, but they are. Maybe the cute humidifier will need to be returned after this experience...

Thank you everyone who posted about power supply interference and whatnot. You led me to a (weird and unexpected!) solution.


I just wanted to share my experience in case it helps anyone, it cost am hours and I almost ended up buying a mouse instead. So, the problem for me was that all of a sudden my mouse started acting erratic on my somewhat old HP laptop. It was like it had a mind of it's own, completely useless. So, after trying removing drivers installing various new ones, rebooting, etc., I gave up for the day. Next day I forgot about it and just took it to starbucks to do some work, magically it behaving fine. So, I though it was probably related to temperature (Boston in winter). Anyway, I come back hope and the problem was back. I started researching online on my phone and came across this thread. The minute i read the possibility of electrical issues, I tried unplugging the laptop power cable and the problem went away, tried it a few more tires, same results - bad on wall power, ok on battery. So, then I realized that I had not used this power outlet before with my laptop (moved to a new house) and tried another one, it worked ok. So, there is something about this power outlet that is causing the issues, I know that there is a refrigerator right next to it. Anyway, problem solved (at least for me). Thanks!


I have a cheapo adapter that causes this problem when plugged in. In this case the laptop is an Acer 4332. I found a workaround today, place the palm of one hand flat on the laptop either just to the left, or just to the right of the touchpad.

Then with the other hand, operate the touchpad.

You should find that the mouse pointer at least follows the finger, and in my case double-tapping works too.

This is much easier/quicker than attaching a piece of silver foil to the case.


I am having Sony VIO VGN-N395E. I encountered the problem regarding touch pad, which suddenly became unstable, I took following actions:

  1. Isolated third pin (Prog) by installation tape . But it did not help much .
  2. Then I went to Sony US site and downloaded the driver for the Pointing Device (i.e. touch pad).

The Problem Solved now .

  • could you add a picture of your third pin isolated?
    – JinSnow
    Feb 26, 2016 at 6:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .