3

I want to turn "Determining Gapless Playback Information" off in iTunes, it is slowing down my system whenever I am adding songs.

2

Afaik, Apple does not provide an option to turn this off in iTunes. Try the method suggested in the 2nd page of this post: iTunes - Determining Gapless Playback Information.

You may also have to turn on the Crossfade option for the above workaround to have an impact: Apple Support:What is Gapless Playback?

| improve this answer | |
  • I wish it worked, I seem to still have the issue. – Daniel Sep 9 '09 at 4:35
  • First link is currently 404ing. – jimmyorr Jul 11 '12 at 11:00
1

The best way is to either to:

right-click and "Get Info" on all items in your library and set to Gapless Album = No. as shown at: http://mikevee.com/39/

or change the properties of the files to read-only as shown at: www.sturmnet.org/blog/2008/11/06/making-itunes-stop-that-gapless-playback-nonsense

| improve this answer | |
1

Ok. I have 15,000 plus songs, samples, sound effects, and various things I use Itunes for. This came a problem my first upgrade. I keep all files on an external hard drive to not bog down my computer. I recently upgraded to windows 7 from vista and had to restart the gapless playback problem?

  1. find the folder where all you music is located such as c/justin/mymusic and rename it to anything new c/justin/mymusic2
  2. Turn on itunes. It should not do too much. It should have no songs to start going insane and freeze.
  3. Go to edit select all and right click all your highlighted songs to get info. It will ask if you really want to edit all the files at once, yes you do, go to the far right tab "options" go to the bottom and select gapless playback and toggle it to say yes.
  4. find the original folder you changed to c/justin/mymusic2 and change back to c/justin/mymusic
  5. Go to edit-preferences-advanced-make sure it is getting songs from original music file click ok. It should now just take some time to load up itunes library. No Gapless Playback Lag!
  6. The crossfade option can also be used which helps but does not work as good.
| improve this answer | |
1

This guy has a great answer – worked for me!

Here’s how to turn Gapless Playback off.

  1. Open iTunes
  2. Select all songs in your library – “Ctrl + A” on a PC – Apple key on the Mac
  3. Right Click and select “Get Info” – It will warn you about editing all files
  4. Check the “Gapless Album” box and set it to “No”
  5. Click “OK” and your files should quickly update
  6. To avoid even having to do this….don’t upgrade past iTunes 6

| improve this answer | |
0
  1. Right-click on the song title.
  2. In the drop down list choose "Create MP3 version"
  3. After iTunes makes the copy (my experience is that the new one is shorter), delete the original song.

Test it by closing iTunes, and reopen to see if that same title is still listed as a track to determine the gapless playback info.

| improve this answer | |
0

If you've got any mp3 files in iTunes, re-encode them as AAC, I found that all the files that cause this are mp3, not all mp3 files do this but some do, I had exactly the same problem and re-encoded my mp3 files and, problem solved!

| improve this answer | |
-1

Simply turn off 'Gapless Playback' alltogether in iTunes preferences.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.