I pay for a 50Mbit/s connection. When I connect modem from ISP directly to my PC, the speed is OK. But since we share this connection, I have to use router.

It's nothing archaic, TP-LINK TL-R402M, but when I connect modem to this router, and then PC to router the speed drops to 10Mbit/s (even when noone else is connected). I have absolutely no idea what causes this, I tried replacing a cable, even borrowed a router to try it with it, but it still acts the same.

  • 2
    Have you confirmed that the ports of the router are configured at Fast / Giga Ethernet? May be the ports are limited to 10Mbps. You can get that information with SNMP.
    – jap1968
    Dec 15, 2011 at 17:20
  • The router is 10/100, it's fairly new. I can't see any setting for speed in router interface. If that is not what you are asking, could you please elaborate on how exactly do I use SNMP to get this information?
    – kovike
    Dec 15, 2011 at 17:38
  • You should examine this SNMP branch: IF-MIB::ifSpeed ( Depending on you OS there are different tools to do SNMP queries. In linux: $ snmpwalk -v 1 -c <community_name> <device_ip> .
    – jap1968
    Dec 15, 2011 at 17:56
  • If you have the router doing NAT, it could be that its CPU isn't powerful enough or its NAT implementation isn't efficient enough to keep up with your WAN link. Try switching the TP-LINK to plain old bridging and see if performance improves.
    – Spiff
    Dec 15, 2011 at 21:04

1 Answer 1


I have run into these problems once before, it turns out many routers just are not prepared for that kind of speed on the WAN side. weather it is cpu speed or not I was never sure. could have been the switch ports for all I know but we fixed it with a new more powerful router. We simply researched specs on routers until we found one that looked like it met the requirements. I don't like to recommend certain brands but there are routers out there that are up to the task.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .