When I click the button below, the video player doesn't expand. I am using Firefox 8.0.1 Windows 7 64-bit. Any ideas how to fix it?

enter image description here

Note: I do not experience this problem in my other browsers like Safari and IE.

  • 1
    Have you tried disabling your plugins to see if one of them is causing it? – SaintWacko Dec 15 '11 at 21:35
  • I tried disabling all plugins/add-ons then re-enabling, it worked for a while but problem came back next day. – IMB Dec 17 '11 at 17:23
  • Do you have any plugins that affect youtube? – SaintWacko Dec 18 '11 at 3:22
  • none directly related to youtube. – IMB Dec 18 '11 at 10:13
  • here are my current: plugins/extensions: i.imgur.com/IOQGI.png Note: It's working fine again now, I didn't do anything but I'm sure it will come back soon :-) – IMB Dec 18 '11 at 10:21

The solution is to clear your cookies from Youtube.com


If you got it working, most likely you cleared your history and cookies or they got reset. Deleting the cookies from Youtube.com fixed the problem for me.

I recently used the Firefox add-on FEBE to restore all my settings/passwords/addons from a previous install of Windows (upgraded some hardware). I believe there was some issue with restoring the cookies from a previous build.

  • I tried clearing cookies and it worked! Thanks – IMB Dec 22 '11 at 11:42
  • Hmm.. Well apparently it keeps coming back. I already cleared cookies twice. Worked for a while then problem's back. Even if I don't do anything just watch videos it comes back after a while. – IMB Dec 22 '11 at 13:59
  • What addons and plugins do you have installed? – Jack Dec 22 '11 at 22:34
  • These: i.imgur.com/IOQGI.png – IMB Dec 23 '11 at 9:00

Cookie deletion didnt work for me. tried other things, read, watched videos, tried again, nothing!

Then, I simply went into my add-ons, and disabled some. Still nothing. Then disabled more. Nothing. Of course, Firefox wanted to re-start itself after each round of disabling add-ons, I should add. Then disabled a few more, and it was fixed.

Then I, of course, re-enabled everything I had disabled, came back to youtube, and now the "small player" option doesnt work. Which is fine with me.

So it appears that one, or more, of my add-ons was interfering with THE OPTION BUTTONS for the large and small player, instead of something more complicated which was limiting the size of the player.

Try that, those of you running FF 15.0.1 and running Windows XP Pro SP3.

  • Flashblock is the culprit for me, and as of version 1.5.16 (nightly) the problem still persist. Disabling Flashblock makes the buttons work as they should, for me anyways. – Eric Fortier Oct 7 '12 at 3:12

I have the FlashBlock add-on installed in Firefox, and clicking "Allow Flash from this site" on the FlashBlock icon in the toolbar and reloading the page solved it for me. No need to disable the entire add-on.

An added bonus: After selecting large player on YouTube, I then disallowed Flash from YouTube in FlashBlosk, reloaded the page and now the player is stuck in Large mode, just the way I want it.


Here's what worked for me!

I have Ad Block Plus as an extension, and you have to add an exception in AdBlock settings for youtube.com or s.ytimg.com and the issue should be gone. You should have full control over the video and it's options.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.