163

In a case of mine a very high (compared to the video stream) resolution graphical frame (saying "access denied" (when my IP changes)) can appear instead of a video stream, which makes VLC window to resize, getting bigger than my screen is. This annoys me. Can I set up VLC to never resize its window when I don't do it myself and resize content instead?

7 Answers 7

193

It is really tricky to find the checkbox that needs to be un-checked, so you could go edit the rc file (but don't use notepad.exe to do so, as the file will not be formatted).

C:\Users\%USERNAME%\AppData\Roaming\VLC

--- vlcrc.default       2011-12-16 11:46:51.000000000 -0800
+++ vlcrc.noresize      2010-12-05 20:00:26.000000000 -0800
@@ -1088,7 +1088,7 @@
 #qt-maximized=101

 # Resize interface to the native video size (boolean)
-#qt-video-autoresize=1
+qt-video-autoresize=0

Here is where you find the option in the interface.

VLC disable resize

8
  • 14
    PS, it was an extreme PITA to find that the first time I was looking for it. I actually dug into the vlc source before I figured out where they hid that stupid checkbox.
    – Zoredache
    Dec 16, 2011 at 19:57
  • 8
    You also have to set VLC to USE the QT interface.
    – Mindwin
    Jan 18, 2014 at 19:42
  • 2
    +1. Went to the HUGE trouble of actually logging into the site to upvote. That's huge for me bro. lol thanks for the great answer.
    – user72945
    Feb 12, 2014 at 2:51
  • 3
    Note that this can also be achieved temporarily with the --no-qt-video-autoresize command line flag
    – WirthLuce
    May 25, 2014 at 13:49
  • 16
    requires closing and opening before the new behavior takes effect. Sep 18, 2016 at 21:06
127

Select Tools ⇨ Preferences ⇨ Interface then uncheck the box Resize interface to video size.
Finally, restart VLC.

enter image description here

6
  • 10
    This answer is more up to date. The other (accepted) answer seems to apply to older VLC versions prior 2.xx.
    – nixda
    Sep 15, 2013 at 13:09
  • 14
    make sure to restart VLC (as stated above). it really is necessary!
    – Simon
    Jul 5, 2014 at 5:28
  • 5
    The older answer works if you have the "Show All" or whatever it's called enabled, but this is definitely the quickest way to the solution, nowadays. May 1, 2015 at 19:08
  • This answer actually highlights which checkbox to modify. Jan 30, 2017 at 15:37
  • When I started a video VLC was always maximized. The box was checked by default. So I did: uncheck box > restart VLC > check box again > restart VLC. Now whenever I start a video the window resizes to the video original size which is what I wanted. This is in Ubuntu, for some reason the correct behavior wasn't being applied even though the box was selected by default upon installation of VLC.
    – Daniel
    Oct 1, 2017 at 15:38
18

First choose the window size you like the VLC window to be.

Then hold down the Ctrl and close the window with the X icon.

When you reopen VLC, it should open the window in the same size you closed it.

2
  • Thanks, this worked for me and is exactly what I needed.
    – KoKo
    Jul 8, 2015 at 15:39
  • 1
    +1 That checkbox in settings doesn't make sens, but this method made the trick. Thanks!
    – zur4ik
    Feb 26, 2017 at 21:43
2

From the VLC documentation, I found:

--sout-transcode-maxwidth=<integer>
  Maximum output video width.

--sout-transcode-maxheight=<integer>
  Maximum output video height.

However, running VLC from the command line requires a lot of setup (including settings from the standard module and the transcode module), so you may want to take a look at their Examples.

I'm going to install VLC on this computer and look into setting max sizes through the GUI. I'll report back if I find anything.

2
  • 2
    I am almost certain that he doesn't want to transcode anything, he just wants the interface to stop resizing.
    – Zoredache
    Dec 16, 2011 at 19:53
  • Way to go, @zoredache! I voted for you. Dec 16, 2011 at 19:54
0

I unchecked Lock Aspect Ratio and Resize interface to the native video size.
This can be found under Interface > Main interfaces > macosx or qt
Make sure to click Show All to see these preferences.

-1

The best way to do it to press Ctrl + H when you open a video.

You can then resize it accordingly.

-1

Select Tools ⇨ Preferences ⇨ Interface then uncheck the box Resize interface to video size and the box Integrate video in interface, restart.

Start movie now, if you notice there should be 2 windows the main and the video window in 2 separate windows now.

Go back Select Tools ⇨ Preferences ⇨ Interface then check Integrate video in interface Finally, restart VLC.

The video windows return normal to its default inside the main window now the movie stay in the location you want, resize as you like, close the movie open and notice stays in the size you have choosen.

I don't know how it this but after trying that's how it works for me.

Other option I have found is:

enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.