6

I think most of the info is in the question but here's a little more detail on what I'm trying to achieve.

I control VLC via my Android phone and the VLC Remote app. It works just fine, but I'd prefer to run a different service on port 8080. I'm running VLC on Windows 7 64-bit.

To be clear, I have VLC running on my PC, displaying the content on the PC, but the control is handled by the smartphone.

I have enabled HTTP interface through "Preferences -> All -> Interface -> Main Interfaces -> HTTP remote control interface"

I have checked inside "%APPDATA%\vlc\vlc-qt-interface.ini" and couldn't find anything relevant. I also checked "%APPDATA%\vlc\vlcrc" however there are a lot of settings in there I don't yet understand.

5 Answers 5

6

In the vlcrc file %APPDATA%\vlc\vlcrc Search for the setting http-port=

There are three settings that contain http-port but only the one which is only http-port is the correct one to modify.

2
  • Might be worth also mentioning that you need to uncomment the line by removing the # at the start of the http-port line. So the line only contains http-port=9999 (or whatever port number you want to use.
    – localhost
    Apr 15, 2022 at 16:07
  • On MacOS you can find the vlcrc file at ~/Library/Preferences/org.videolan.vlc/vlcrc
    – Lasf
    Dec 24, 2022 at 11:18
2

You can start it using certain parameters to modify the port number, as dictated by the VLC documentation.

vlc -I http (--http-src /directory/ --http-host host:port)
3
  • Thanks for the suggestion but this doesn't seem to do wat I need. I ran "vlc -I http (--http-src m:/media/ --http-host 127.0.0.1:8001)" and I can see in TCPView that port 8001 is open but I can't raise it through the remote control app. Nor can I raise it through the browser
    – G-.
    Dec 19, 2011 at 21:58
  • vlc -I http (--http-src "C:/Program Files (x86)/VideoLAN/VLC/http" --http-host 127.0.0.1:8001) This also doesn't show anything on the PC monitor I'd really appreciate if you've any other ideas?
    – G-.
    Dec 19, 2011 at 22:04
  • Beyond what the documentation provides, I have no clue Dec 19, 2011 at 22:10
1

I found the answer here:

http://forum.videolan.org/viewtopic.php?f=14&t=77837&p=255857&hilit=change+port+http+interface#p255857

The following is a quote from user VLC_help:

"Tools -> Preferences... (Show settings: All) Interface -> Main interface -> HTTP and put the port to Host address field (so :9090). Save and restart.

I set this to 0.0.0.0:8001 and it works. Image is shown on PC and control is handled by the phone.

I have tested this and found it to be working on "VLC media player 1.1.11 The Luggage".

1
  • 1
    There is no Main interface -> HTTP and no HTTP Port showing in the user interface on VLC 3.0.11 it is now using a Lua Web interface. Answer by Matt Vukomanovic to edit the %APPDATA%\vlc\vlcrc and uncomment and change http-port= solves this for me. Dec 26, 2020 at 17:33
0

From the command line:

"C:\Program Files\VideoLAN\VLC\vlc.exe" --extraintf=http --http-host=127.0.0.1 --http-port=9099 --http-password=abc videotoplay.mp4

This sets it to listen on port 9099 with the password "abc".

Then you can go to http://127.0.0.1:9099/ in your browser to control vlc.

Alternatively you can edit the vlcrc file as described in the other answer.

-1

just click + plus sign, change port number and click add. it's going to re-write your port each time you try to stream anyway. check your firewall too, it kinda messed me up for a while.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .