1

The situation

I download happily torrents with uTorrent for a long time, maybe 12 hours.

Suddenly, I notice my connection stopped working.

When I check uTorrent is still downloading stuff.

When I check other computers in the same network their internet connection works properly.

I can ping other computers in the network, but I cannot ping any remote IP.

What I tried

When I close uTorrent and open it again, it is unable to generate new connections.

Once I disable and enable my network card again connection works again, yay!

Once I open uTorrent again the same problem comes back, buh!

It's only when I restart my computer when the problem is solved and I can happily download torrents again, yay!

I also tried using a cable instead of WiFi, and the problem also happened.

My guess

The problem seems to be generating new connections, since uTorrent keeps downloading once the whole computer cannot use the Internet. And after I restart it, it cannot start downloading anything.

  • Since it happens with 2 different network cards, the problem doesn't seems to be the network card.
  • Since I restarted uTorrent tons of times, I don't think is that either.
  • So what is between uTorrent and the network cards? Network services, so my guess is that the problem is caused by one of those.

I already restarted my computer this time, but what I'll try next time is to restart all the running network services, and check what happens if I change between LAN/WAN on the fly.

Any help is very welcome ^^

2
  • 1
    Have you tried upgrading your network drivers? Dec 20, 2011 at 10:56
  • No, the latest Atheros drivers crash my computer. Also as I said I don't think is the network card issue, this also happens when I'm using another LAN network card.
    – Zequez
    Dec 20, 2011 at 12:22

3 Answers 3

1

Sounds to me like your connection is being saturated and you need to adjust your uTorrent settings accordingly to allow some 'breathing room' for your connection whilst downloading.

This guide is written for Vuze but with a little bit of research you can adjust the settings so that they apply to uTorrent:

http://wiki.vuze.com/w/Good_settings

4
  • I have those settings very low. When this happens to me is after a lot of hours of full speed downloads, so I doubt it's because of the torrent settings, which are already pretty low.
    – Zequez
    Dec 20, 2011 at 12:13
  • @Zequez "a lot of hours of full speed downloads" explain full speed.
    – Moab
    Dec 20, 2011 at 15:33
  • Torrents downloading at the max speed of my Internet connection.
    – Zequez
    Dec 21, 2011 at 7:07
  • Yup; if the NIC or router die or slow down, then just reduce the number of connections in the Bandwidth section of the Properties dialog.
    – Synetech
    Jul 23, 2012 at 6:14
1

This solved it for me for both desktops and laptops:

  1. Open run command & type devmgmt.msc & hit enter (Or Click Windows key and type 'Device Manager')

  2. Find your network adapter, right click it and choose Properties enter image description here

  3. Go to Power Management and uncheck "Allow the computer to turn off this device to save Power" enter image description here

  4. Open run command again & type powercfg.cpl & hit enter (Or click windows key and type 'Edit Power Plans', then click Power Options at the top bar to go back one screen) enter image description here

  5. Set your computer's power plan to the higher setting & up it again if problem persists (For example if it was on balanced, put on High Performance)

0

openwrt >>

Network -> Wireless -> SSID Edit button -> Advanced Settings -> Disassociate On Low Acknowledgement -> uncheck --->>> Allow AP mode to disconnect STAs based on low ACK condition

/etc/config/wireless

uci set wireless.default_radio0.disassoc_low_ack='0'

You need to turn router log. Then restart router. Start torrent test and ping from router and from your machine. Then check log. The most case for this problem is related to out of ram memory. It will show you error like this one: "Kernel errors (ath: skbuff alloc of size 1926 failed ) (32 MB RAM ...".

One of the resolution is to add more swap and then to check if the swap is using and if it slow what will be benefits of all this. If your router is too old and not have usb you need to decrease max connection in torrent client config also.

Check here https://forum.openwrt.org/t/kernel-errors-ath-skbuff-alloc-of-size-1926-failed-32-mb-ram-device/102180

1
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Sep 7, 2023 at 17:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .