38

My Snow Leopard macbook is set to Set date and time automatically: Apple Americas/U.S. (time.apple.com), but despite sitting idle for several hours (with internet connection), it has yet to do any syncing, the date remains off by ~2 days.

2
  • Try toggling it on and off to force a refresh. Dec 20, 2011 at 15:00
  • How about trace routing time.apple.com and then trying a different ntp client against that server? Dec 20, 2011 at 15:59

5 Answers 5

66

From terminal:

sudo ntpdate -u time.apple.com

macOS Catalina:

sudo sntp -sS pool.ntp.org

5
  • 1
    Seems to work fine in El Capitan too. Dec 14, 2015 at 13:59
  • 1
    Still working in macOS Sierra.
    – Nick
    Apr 17, 2017 at 20:01
  • 2
    Confirmed working in High Sierra as well.
    – khadafi
    Nov 24, 2017 at 14:21
  • Confirmed still working in HS.
    – yiwei
    May 2, 2018 at 23:59
  • 14
    Confirmed NOT working in Mojave, as ntpdate and co have been removed. See this excellent answer for up-to-date instructions.
    – Alex Ryan
    Sep 5, 2019 at 17:55
4

Per the ntpdate man page, the accepted answer will become obsolete when ntpdate is retired. If you encounter this problem, this will do the equivalent:

sudo ntpd -q 

ntpd : ...sets and maintains the system time of day in syn- chronism with Internet standard time servers.

-q : Set the time and quit.

Sources:

1
  • This was the only command that worked in High Sierra for me.
    – Elad Nava
    Jan 8, 2022 at 18:04
3

I ran these two commands on Mojave:

sudo systemsetup -setnetworktimeserver pool.ntp.org
sudo sntp -sS pool.ntp.org

Following https://superuser.com/a/1479345 following two answers on https://apple.stackexchange.com/q/117864

1

you can go into the system preferences and reset the time manualy, and then set the time to sync automaticly again once you are back up to speed with whatever day/week/month you need. i am not sure why its not syncing with apple, but you can just set the day properly and it will be accurate as long as you dont cross too many time zones.

1
  • 2
    Many time sync utilities have safeguards, where they won't sync if the time difference is too large, to prevent disasters if, for example, time server is compromised, etc. So, set the time roughly right manually, then it should sync by itself.
    – haimg
    Dec 20, 2011 at 16:05
0

The currently accepted answer does NOT work in Mojave, as ntpdate and co have been removed.

See this excellent answer on the Apple StackExchange for up-to-date instructions.

3
  • 1
    Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Apr 7, 2020 at 15:48
  • The linked answer is more likely to be updated with new helpful information than it is to disappear. Links were invented precisely so that we don't have to copy-paste information everywhere it's used. Unnecessary denormalization is bad! 🙂
    – Alex Ryan
    Apr 8, 2020 at 16:57
  • 2
    Unfortunately that's not what we do here. We are not Wikipedia. A class example is Microsoft who broke huge numbers of links and deleted the content. Please follow the Stack Exchange conventions as instructed. Please read Your answer is in another castle: when is an answer not an answer? - Meta Stack Exchange
    – DavidPostill
    Apr 8, 2020 at 17:02

You must log in to answer this question.