6

I have a Kingston flash drive which works fine in every computer that I insert it. But in my Windows 7 it doesn't mount anymore.

Why this is happening ? When I insert the flash drive it seems that the Windows 7 recognize it, but when I hover the icon don't show the flash drive to remove it, as usually does.

Any idea ?

Thanks.

enter image description here enter image description here

Any idea ?

Abrir Dispositivos e Impressoras, means, ' Open devices and printers' .

  • 1
    Do other USB drives work in that USB port? Maybe it's dead/dying Have you tried checking Sevice Manager for the device? Have you tried plugging it into another USB port? – Canadian Luke REINSTATE MONICA Dec 20 '11 at 16:10
  • yes dude, I already tried to do that, it seems a problem in the machine, not in the usb flash drive. – Valter Silva Dec 20 '11 at 16:31
  • So, "dude", do you mean that the USB port is not recognising any devices? If this is the case, please answer your own question and mark it as closed. – user3463 Dec 20 '11 at 16:44
  • @RandolphWest, I don't understand the meaning of the double quote in "dude", what is it ? Why close the question if the problem is not in a specific port ? In any port that I plug, the flash drive is not recognized. – Valter Silva Dec 20 '11 at 16:57
  • 1
    Do any other usb devices work in the usb ports? With the drive plugged in open device manager and look for any usb errors. Does the drive show up in windows explorer? – Moab Dec 20 '11 at 18:11
6

I found the solution to my problem here:

http://social.technet.microsoft.com/wiki/contents/articles/3409.aspx

Thanks to everyone by the help.

Remove the INFCACHE.1 file, Perform the following steps to remove and rebuild the INFCACHE.1 file.

  1. Disconnect all USB deviced except the keyboard and mouse. (Desktop only) (Laptop remove all usb devices)

  2. Open Windows Explorer by right clicking on Start, and then clicking on Explore.

  3. In the address bar, type

    C:\Windows\System32\DriverStore

  4. Locate the INFCACHE.1 file, right click on it, and then click Properties.

  5. In the INFCACHE.1 Properties dialog box, click the Security tab, and then click Edit.

  6. In the User Account Control dialog box, click Continue.

  7. In the Permissions for INFCACHE.1 dialog box under the Group or user names section, click Add.

  8. In the Select Users or Groups dialog box in the Enter the object names to select text box, type Administrators, postfixed with a 's', and not only Administrator. If you only choose the Administrator account you will not be able to delete the file. After that, click OK.

  9. In the Permissions for INFCACHE.1 dialog box in the Permissions for Administrators section, select to allow Full Control, and then click OK.

  10. In the INFCACHE.1 Properties dialog box, click OK.

  11. In the Windows Explorer window, delete INFCACHE.1, before deleting it, you can make a backup copy of this to another folder of you wish.

  12. Connect a USB device other than the one that Windows had trouble detecting. This forces Windows to rebuild the INFCACHE.1 file.

Note: This detection issue can happen several times in a row. If so, repeat steps 1-12 until the device is detected.

  • En anglais, s'il vous plait? – Canadian Luke REINSTATE MONICA Dec 20 '11 at 18:30
  • 2
    Link-only answer are a no-no due to possible future link-rot, please include pertinent information (in English) within your answer. – Ƭᴇcʜιᴇ007 Dec 20 '11 at 21:55
  • Good find. I've voted up your answer. – user3463 Dec 21 '11 at 0:21
  • Worked for me after searching for weeks. Thanks a lot. Mucho Gracias – Abhishek Oct 18 '12 at 19:04
  • Unfortunately this did not solve my problem. :/ – tftd May 31 '13 at 3:52
2

I had the same problem. My thumb drive always worked on my main computer running Windows 7 with no problems. All of a sudden for no reason whenever I plugged it in it would show up under computer but not showing the correct volume name and when I tried to access it I would get an error message. The thumb drive still worked perfectly in all other computers, including my laptop also running Windows 7, and two computers at work, 1 runng XP and the other running Vista.

This is what I tried as a long shot and it worked. I backed up my thumb drive on to my laptop and then I formated the thumb drive. After that it worked fine in my main computer again. if anyone is havibg the same problem try this, it worked for me.

0

You need to change Group Policy. First, launch it by going to the Run dialog and entering

gpedit.msc

Then, navigate to

Computer Configuration > Administrative Templates > System > Removable Storage Access

Lastly, disable Deny execute access, Deny read access, and Deny write access under Removable Disks.

Not the answer you're looking for? Browse other questions tagged or ask your own question.