I changed my password using sudo passwd. The length of the new password is 100 characters. Then, when I tried to login again, it no longer allowed me to enter my remote computer, access was denied always.

What is the maximum allowable length for a password?

I copied the password from my password generator program, and pasted it to putty using right click.

What is using keyboard-interactive authentication? Is that the problem I am having?

  • 1
    good job and well done! – ajreal Dec 21 '11 at 4:42
  • How are you trying to login? Using ssh? – trojanfoe Dec 21 '11 at 8:23
  • Yes, i'm using ssh to login. Is it safe to use ssh when logging in as root user? – Kevin Lee Dec 21 '11 at 14:07

When you ran sudo passwd, you didn't change your password - you changed root's. If you did this while logged in to a standard user account, your own password was unaffected.

Try logging in using your old password.

On modern configurations, the maximum password length is not set explicitly. Some programs may simply truncate inputs at some number such as 4096 bytes, but this is only an implementation detail, and honestly if you need such a long password then you don't need a password at all, simply lock the account. 100 characters is okay.

keyboard-interactive is not a "problem" but a SSH authentication method consisting of textual requests and responses. In other words, the server simply asks you to enter some data (password, verification code).

| improve this answer | |
  • Hello grawity, Thank you. I solved the problem already. I can login in using the web shell in Linode's dashboard, and manage to change it from there. – Kevin Lee Dec 21 '11 at 14:08

You've changed the password of your low-user.... the sudo command gives you rights to execute with root level privileges, but for direct actions on the user, you must specify which one.

If you want to change the root password when or you are not 'root', two easy ways:

# sudo passwd root

here, you specify you want to change root, without this, if you are on a prompt open by 'geronimo', you've just changed the geronimo's password.


# su -

log you into root with the generic password, after, you are 'root' for real.


# passwd

(if I've understood your problem, you can't try the second method to fix your mistake).

The sudo command elevates your permission level to that of root (when you type their password) to execute a command or action, when you use 'sudo', you are not root, you just do everything like them.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.