I'm trying to install the latest jdk (7u2) onto my Windows XP laptop and for some reason when I double-click the jdk-7u12-windows-i586.exe, no automatic pop up comes out like how I expect it to for the installation. Would anyone know any reasons why it would do that or how to debug this? I have uninstalled any older Java versions, so it should be a clean slate, but nothing is still coming up when I double-click the installer. I have also tried to run the installer on the cmd but nothing comes up as well. I don't get any warnings or errors. Thank you.

Edit: The installer is not corrupted. I have tested the installer on another WinXP machine and it works fine. I am thinking my setup is somehow messed up or one of my other programs are blocking it.. I have disabled a virus scan .exe process in my Windows Task Manager already but it must be something else...

  • There should be a log in C:\Documents and Settings\User\Local Settings\Temp. If not, run the installer from the command line with the option jdk-7u12-windows-i586.exe /LV* C:\jdk.log (Or your desired path and filename.) Let's see what the log says. – Aaron Copley Dec 21 '11 at 20:30
  • 1
    Download the installer again. It was corrupted during file transfer. – mailq Dec 21 '11 at 20:33
  • @Aaron Copley - I tried your command, but it seems like no jdk.log is saving in the C:\ directory. (??) – O_O Dec 21 '11 at 20:45
  • @mailq - I redownloaded the installer but I am still having the same symptoms. I am assuming that downloading the jdk does not require a jre since I believe the jdk emcompasses the jre as well... – O_O Dec 21 '11 at 20:46
  • Are you running as Admin? – Aaron Copley Dec 21 '11 at 21:08

This bug is believed to be due to the way that the JDK7 installer was configured. The configuration has been changed for 7u6.

Can you try with 7u6 and let us know if it resolves the problem?

Bug if you are interested: Bug ID: 7145760 JDK Installation broken on WinXP since 7u2, worked in 7u1


To edit the PATH environment variable in Windows 2000/XP/Vista/7: Click the "Start" button ⇒ "Control Panel" ⇒ "System" ⇒ (Vista/7 only) "Advanced system settings". Switch to "Advanced" tab ⇒ "Environment Variables..." In "System Variables" box, scroll down to select "PATH" ⇒ "Edit..." In "Variable value" field, INSERT "c:\Program Files\java\jdk1.7.0\bin" (assume that this is your JDK's binary directory) IN FRONT of all the existing directories, followed by a semi-colon (;) which separates the JDK's binary directory from the rest of the existing directories. DO NOT DELETE any existing entries; otherwise, some existing applications may not run. Variable name : PATH Variable value : c:\Program Files\java\jdk1.7.0\bin;....exiting entries....

  • It's always a good idea to include full answers rather than providing a link as an answer. If that link goes stale in the future, this will lead someone with the same problem to a dead end. Links are ok for additional reading or reference. – Aaron Copley Dec 21 '11 at 20:35
  • I checked the C:\Program Files\ folder and found a Java folder with empty jre folders and I deleted that. I again retried double-clicking the installer, but it is a no go. :( I don't think the path matters if the jdk isn't even installed yet.. – O_O Dec 21 '11 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.