11

My MBP comes with a Turkish keyboard but I'm using US layout. However, the key just under ESC gives § instead of ` (back-quote) which I frequently use.

I need to remap this key but I couldn't find any information except remapping of modifier keys. How can I do it?

  • As a side point, on my keyboard (UK) the backtick is between the left shift and Z keys – Xetius Sep 7 '09 at 11:03
  • Another side note, that symbol is there in all layouts I've seen. – Tiago Veloso Sep 7 '09 at 11:13
  • normally it is just under ESC key in windows and linux pcs. at least that is more accesable for us that deal with linux, latex, lisp. And finally it is used for switching application windows in Mac OS X. – Ahmet Sep 7 '09 at 11:50
  • 1
  • thank you Nippysaurus but doublecommand takes care of only modifier keys. backquote is not covered by it. i've tried both and found keyremap4macbook more powerful – Ahmet Sep 8 '09 at 7:20
15

Try KeyRemap4MacBook. It seems to offer a lot of options. Maybe it will fix your problem as well. Here's what it says about it:

This is a very powerful keyboard remapper for Mac OS X. In addition to simple key remapping, it has special remapping modes like Emacs-mode, SandS-mode (Space and Shift).

| improve this answer | |
  • Perfect solution Alex. Did a find on § on KeyRemap4MacBook's UI and found the feature of Remapping Paragraph(§) to Backquote (`). Thank you – Ahmet Sep 7 '09 at 10:49
  • It's odd how I couldn't find this application after searching so much – Ahmet Sep 7 '09 at 10:50
  • I searched for macbook key remapping. Maybe you just checked for mac key remapping :). If this worked for you, please consider marking it as the accepted answer. – alex Sep 7 '09 at 10:57
  • Oh, by the way, glad it worked for you :) – alex Sep 7 '09 at 10:58
  • Love it! Found my exact case! It means I am not the only one with this weird mapping problem - Apple should listen to users... – Magnetic_dud Apr 20 '12 at 13:33
4

Mac 10.12 sierra users should use this: https://github.com/tekezo/Karabiner-Elements

DMG download: https://pqrs.org/latest/karabiner-elements-latest.dmg

In "From key", I selected the option with Japanese characters and in To key I selected GRAVE_ACCENT_AND_TILDE (`).

image

| improve this answer | |
  • 2
    Instead of the Japanese characters, I'm using non_us_backslash. You can view the exact character you need to map from Karabiner-EventViewer app. – ceilfors Apr 4 '17 at 8:37
  • Yes! I cannot believe that so few people are having this problem. This worked great for me--just a small issue I have is that now when I type "˜" I get small tilde initially instead of the one I want (~) for that to happen I still need to press space. Any ideas how to get rid of that? – Jakub Langr Oct 7 '18 at 22:33
1

You can use the hidutil command-line tool, which comes with macOS since Sierra 10.12:

hidutil property --set '{"UserKeyMapping":[{"HIDKeyboardModifierMappingSrc":0x700000064,"HIDKeyboardModifierMappingDst":0x700000035}]}'

The keys are referenced by Usage ID from the USB HID Usage Tables Specification. The section key § is listed as "Keyboard Non-US \ and |" (0x64, see https://discussions.apple.com/thread/8133633) and backtick ` is "Keyboard Grave Accent and Tilde" (0x35).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.