-1

I have a home server running Debian Lenny. I am trying to install iStat Server on it, but it just doesn't want to work. I got it working on an other server, also running lenny... it worked straigt "out of the box".

When I run the configure script, this is what I get:

~/istatd-0.5.7# ./configure 
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for ranlib... ranlib
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether the C++ compiler works... no
configure: error: in `/root/istatd-0.5.7':
configure: error: C++ compiler cannot create executables
See `config.log' for more details.

What is wrong?

2 Answers 2

0

You are missing your c++ compiler. Try to install gcc and g++ (Not sure exactly how the packages are named in debian, it might be gcc-c++).

1

You may be missing other development packages as well, but at a bare minimum you need to install the build-essential package and its dependencies.

sudo aptitude install build-essential

Depending on what you're trying to build, you may need other development libraries, headers, and so forth. For example, your project's readme.txt clearly lists libxml2-dev as a dependency, so you'll need to include that as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.