I just built a new PC with an ASUS P8P67 LE motherboard. This board has two Marvell SATA ports, one of them is a regular SATA port and the other one is a back e-SATA port (colored in red).

My e-SATA port worked fine with the stock drivers that Windows 7 x64 installs automatically. With those regular drivers, the e-SATA port is treated as a hot plug port. When I connected an eSATA external hard disk case to that port, Windows detected it and it showed a "Safely remove hardware" icon in the tray. So that's perfectly fine.

But then I installed the "Marvell Magni driver" that came in the CD (because it seemed to be newer than what was on the website), the eSATA port stopped working altogether. No disks were recognized in that eSATA port. So I uninstalled that driver using Windows Control Panel / "Uninstall a program", and in the very same instant I finished uninstalling the driver, the external hard disk I already had plugged was immediately recognized again by Windows and my drive appeared.

But now I don't have the hotplug feature anymore. Now I don't get the "Safely remove hardware" icon when pluggin an eSATA device (only works for USB drives). And also, if I plug a eSATA hard drive during a Windows session, it's not recognized. I have to restart the system to have the disk recognized by the motherboard.

I should have never installed that Magni driver. But now, how do I get the hotplug feature back that I had with the stock Windows drivers? I have already uninstalled Marvell's driver and I can't hotplug, which I could do before installing it.

In the BIOS there are options for all the Intel ports (all 4 SATA 3G ports and also the 2 SATA 6G ports, also by Intel), but there is no option for the single SATA port by Marvell and there isn't any option either for the the red colored Marvell eSATA port at the back.


Try this:

  • Go to Control Panel -> Device Manager
  • Find the Marvell SATA controller, and open its properties.
  • Go to the "Driver" tab

From there, if possible, click the "Roll Back Driver" button. If the button is grayed out, try uninstalling the driver, and it should automatically install it again on reboot.

  • Thanks for your answer. I already tried looking for any instance of "Marvell" in the Device Manager, but I didn't find any. BTW, why did my question get downvoted? – OMA Jan 1 '12 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.