Patience please: this is a for dummies question. I've never used a console before and I started to learn Ruby. I use cmd.exe in Windows, but it's bland and has no colour coding, which hurts my eyes.

I did some research and came across this thread: https://superuser.com/questions/87441/alternative-windows-command-shell-and-console

Console 2 is a nice alternative, apparently. I downloaded it, but I doesn't seem to do what I want it to do, and I don't know where to put it. It has no installer. For example, if I type ruby --version it tells me ruby is not a recognized command. I understand I might have to configure something, but I can't find any relevant documentation, and I don't know where to put the program, or if that matters.

How do I get it to work as a replacement for cmd.exe, or at least recognize my commands like git version and ruby version etc... ? A "not so technical" explanation would be really helpful.

  1. Console2 is not a replacement for cmd.exe and not an alternative shell, it's just command-promt window with some makeover
  2. It has the same rules as pure cmd.exe (regarding "... not found" errors), thus - you have to resolve PATH-issues separately
  3. Console2 doesn't require any installation (yes, such programs without overbloated installers still exist in wild), just extract archive into any location and start Console.exe
  • Thanks for clarifying. But if I launch cmd.exe, all my commands work normally. If I launch Console2, nothing does. So what I am doing wrong? – Mohamad Dec 23 '11 at 15:50
  • 1. Check PATH in cmd.exe window and in Console2 window 2. Define by hand cmd.exe as shell in main console settings (Edit - Settings - Console) and in tabs settings for single "Cmd" tab (Edit - Settings - Tabs) – Lazy Badger Dec 23 '11 at 16:13

I had a similar problem. I had just added a directory to the command path, cmd.exe was picking it up, but not console2 for some reason. Check your path by typing "path" into both console2 and cmd.exe. In my case the paths were the same, except for the recently added directory. I rebooted, tried again, and abracadabra, it works now.

There is a bug already filed: http://sourceforge.net/tracker/index.php?func=detail&aid=3520244&group_id=43764&atid=437332

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.