When I restore a ~500 GB disk image made with Windows 7's built-in system image tool, it runs for 8-10 hours with very little progress, and even after 3 days it is still only about 30% done.

Why is this happening, and what can I do to fix it?

Background/original version of question

I've been using Windows 7's built-in backup program to back up my 1 TB boot hard disk to another 2 TB internal disk drive, choosing to create a boot-drive system image along the way. I've tested the backup drive by occasionally restoring a few files from backup and manually verifying the contents, but never had the chance to try restoring the image. The last such manual test was a few weeks ago.

My system started acting up in the past few days, so I decided about 12 hours ago to restore from the latest image, created last Sunday. So, I booted from a Windows 7 install disc and chose to "Recover from the system image" instead of installing. I kicked off the recovery with the default options, and then I went out for the day. With the ~500 GB of used space on the boot drive, I figured it would be a full 8-12 hours before the recovery completed.

9 hours later, I came back, and not only is the recovery not done, the progress meter has barely budged from the start. Maybe 3-5% progress at most, although there is no percentage or estimated time remaining, so I can't tell whether it's just going very slowly or if it's hanged altogether. Assuming the latter, I've decided to just cancel the recovery (and by "cancel", I mean hard-reset the machine) and reformat the boot drive altogether before trying the restoration again.

So, here's my question: is it really to be expected that, with ~500 GB of data to restore, that it would really take days to restore the system image? And if not, what could be causing the problem?

1 Answer 1


As it turns out, I have the chipset's* SATA controller set to AHCI mode instead of PATA/IDE emulation mode in the BIOS setup. Other people have found that switching the SATA controller from AHCI mode to IDE mode in the BIOS suddenly makes the image restore go much, much faster.^ I tried this, and lo and behold, the restore finished in less than two hours and booted to a working system.

Although my chipset is made by Intel, this is not an Intel-specific problem: a Google search for windows 7 image restore slow ahci leads to this video which shows the same solution on an AMD box.

* The motherboard is a Gigabyte EP45T-USB3P, which has an Intel P45 chipset with an ICH10R southbridge/SATA controller.

^ At first, when I suspected AHCI mode was the problem, I tried downloading the latest AHCI driver from Intel and loading it into the Windows 7 recovery environment. In my case, the driver installation failed, but installing the driver may well work for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .