an hour ago I had a working gnome-desktop on my debian system (thinkpad x121e).

Then I installed compiz that crashed.

After a reboot the gnome-desktop no longer started.

Then I did some upgrades with aptitude, all gnome-packages seem to be there, but it is still not working.

On startup I get a login-dialog, when I login there is no desktop, only some window-manager running that allows me to start a terminal.

When I run "gnome-session" I get the error message "failed to load session "gnome".

So how do I get back to a working desktop?

I have tried "tasksel install gnome-desktop --new-install" but that just displays a progress window that after half an hour still shows 0%.

Can someone help me please?

I have tried "

6 Answers 6


Try doing this in terminal

sudo apt-get update
sudo apt-get upgrade #see if the package is held back
sudo apt-get purge gnome-session
sudo apt-get install gnome-session

Source: http://ubuntuforums.org/showpost.php?p=10783266&postcount=5


first of all sudo apt-get purge gnome-session.

after all purging the gnome session make sure to clear packages by using bellow command sudo apt-get autoremove sudo apt-get autoclean

and than sudo apt-get install gnome-session it will work most the time when tasksel fail to install gnome.

i have tested this code on debian jessie and ubuntu lts 14.04.

i have this kind of crazy issue once i have messed up with gtk or multiple session at a time So also.

this will help you out form the session issue.


After upgrading from Squeeze to Wheezy a virtual machine running on KVM, I had to install "gnome-session-falback" in order to open successfully a session in gnome:

sudo apt-get install gnome-session-fallback

You will need to install aptitude and tasksel before install gnome

Aptitude is an Ncurses based FrontEnd to Apt, the debian package manager.

Tasksel is a tool that installs multiple related packages as a co-ordinated “task” onto your system.

# apt-get install aptitude tasksel

Install gnome on debian

# tasksel install gnome-desktop --new-install

from http://namhuy.net/1085/install-gui-on-debian-7-wheezy.html


I discovered that I was missing Xorg. Installed it with this;

sudo apt-get install xorg

If somebody reaches this question, while investigating the similar issue when login-page wasn't even showing in gnome 3, go to recovery mode, and select "resume" (which will lead you to the terminal of your user), or hit alt + F2 if are on the actual blank screen (which will bring out terminal) and run the command:

sudo apt-get install gdm3

(depending on your current configuration, you might need to change gdm3 with lightdm)

Seems like, for whatever reason, this package got uninstalled.

If you have it already installed, and it is not working correctly, you can call before the above command:

sudo dpkg-reconfigure gdm3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .