Using Excel 2007, every time I press the "-" key, the extend selection mode is activated. Notice that in other programs the "-" key works as expected. This is very frustrating since I cannot input negative values.

I can disable extended mode by pressing [F8], but the next time I press "-" it comes back!

How can I solve this annoying problem?

  • My guess is that you are using a RDP connection. If I am right, I have the solution. It is a bug of rdesktop versions 1.5 and 1.6. You have to downgrade to rdesktop 1.4 to solve the issue.
    – Toc
    Oct 20, 2009 at 15:34
  • What is the solution?
    – Firee
    Jan 8, 2016 at 13:01

8 Answers 8


I had this problem and found that there's actually a very simple solution.

Assuming you are having this problem with some sort of synergy client, what you need to do is press numlock on a keyboard attached to the machine having the problem. The extend selection issue is a direct result of the client machine's numlock being turned on and because synergy cannot turn it off.

Hope that helps someone. I struggled with this problem for over an hour. =)

  • I can confirm this works for me, I really don't know why this is even an option.
    – Hugoagogo
    Mar 22, 2016 at 5:43

Press NumLock+- (minus sign) to toggle this problem away.

Don't ask me why this works, because I'm still clueless, but I got the idea here when I was searching for answers.



I have a Linux based thin client connecting to a windows server via RDP. I have the extend problem in excel when using the numpad.

I too have struggled with this problem for many months and I fixed it by attacking the source of the problem.

The num pad minus and the minus on the main keyboard are different keycodes.

Remap the keycode in the registry and the problem goes away!!

Here is the regfile that will map the numpad - (minus) to the keyboard - (minus)

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,0C,00,4A,00,00,00,00,0


You will need to reboot but it works straight away!!


I would try a few things to see if you can figure out the root of the problem.

Have you tried a new/different keyboard? Perhaps it's sending an F8 instead of a dash (who knows). You can also try an on-screen keyboard to see if using the - causes the same problem.

You might also check to see if there's a custom keyboard shortcut assigned in Excel. In Excel 2003, you can examine the shortcuts using these steps here.

Lastly, you can try a "Detect and Repair" on Excel/Office, which might be able to fix the problem.

  • In Excel 2003 or XP, select the "Detect and Repair" option from the help menu
  • In Excel 2007, select the Orb, "Excel Options" at the bottom of the menu, then the "Resources" tab, and then the "Diagnose" button.

Do you have Lotus 123 compatibility turned on? Should be able to check in Tools -> Options. I don't have Excel 2003 handy, but in 2007 it's on the Advanced tab.


It sounds like Autocorrect, but I can't imagine how it works. Go to the Office Button - Excel Options - Proofing Options - Autocorrect Options and see if there's an entry for the minus sign. If so, delete it. If that works, be sure to let us know what it was converting a minus into.


I believe I have the solution. It has to do with the NumLock status when you log in and out. Try logging off with NumLock off, turn NumLock on, and then log in. If NumLock turns off, turn it on again and check to see if it is fixed now.

Worked for me.


I remap the minus key on the numeric keypad with the following command placed in a startup script on Linux based systems RDPing to Windows: /usr/bin/xmodmap -e 'keycode 82 = minus underscore'.


  • Device: Raspberry Pi 2 rdesktop to Windows terminal server
  • OS: Raspbian
  • Locale: LANG=en_US.utf8
  • Language: en_US
  • Keyboard: pc105