I tried this in my shortcut target input field but it doesn't work. The dialog box gives me an error message invalid path? "C:\Windows\System32\cmd.exe /C start /high /affinity 3 D:\The Elder Scrolls V - Skyrim\skse_loader.exe". Notice the spaces in the pathname. Is this the space character that need to be escaped?


From your path

"C:\Windows\System32\cmd.exe /C start /high /affinity 3 D:\The/ Elder Scrolls V - Skyrim\skse_loader.exe"

The following part, and especially the slash seems to be most suspicious, since it is not allowed in path:

D:\The/ Elder

I would re-write your target using the short 8.3 name (it is the fake name in the example just to show what it should like):

"C:\Windows\System32\cmd.exe" /C start /high /affinity 3 D:\TheElde~1\skse_l~1.exe

  • I'm sorry, I was too fast. I've tried to escaped the space character with the slash character but I forget to delete in my question. About your suggesting it doesn't work. The path opens a terminal with the path but it is not starting the program. – Gigamegs Dec 26 '11 at 19:16
  • Try converting your long path into short one and you won't need the quotes. You can use dir /x to see the short paths: you'll need that for your Elder Scroll folder and for executable only. – Alexander Galkin Dec 26 '11 at 19:32

I was trying to do something similar in Windows 10 where I needed to append an argument to my Eclipse program shortcut's target, where the argument was a path with a space (C:\Program Files\Java\jdk1.7.0_80\jre\bin\javaw) [note the space in 'Program Files']...

If you just need to resolve the space in the path, surround the path in quotes.

So my argument became: "C:\Program Files\Java\jdk1.7.0_80\jre\bin\javaw"

Accepted Answer by @Phpdevpad helped me figure this out, but the quotes weren't focused on in that solution, so I made this separate Answer.


Problem solved. The start option need a title to work: http://www.vistax64.com/gaming/197915-setting-processor-affinity-made-easy.html. C:\Windows\System32\cmd.exe /C START "Skyrim" /high /affinity 3 "D:\The Elder Scrolls V - Skyrim\skse_loader.exe"

  • 2
    Looks like you surrounding the path in quotes also may have helped. That's the part that helped solve my similar problem, as I just Answered separately (focusing on the quotes). – cellepo Jan 17 '16 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.