1

For more than 6 months, I've had this problem. I can't seem to find a display driver for my ATi Mobility Radeon HD 2300 specific for the Windows 7 32bit.

I don't necessarily need official drivers.. any WORKING modded drivers will also be perfect. I just need to get the Catalyst to run along with that driver.

The current driver is the one from windows update ( a WDDM 1.1 driver ) that obviously has no catalyst support so I removed it using Driver Sweeper.

I tried the DNA-ATi 10.10e4 modded drivers but its driver doesn't install and manually installing the INF files from it doesn't start my driver up either! (after reboot, device manager shows "windows has stopped the driver because it reported an error")

My Laptop is Acer Aspire 5910G and the OEM doesn't have the driver now either.

1

A lot of laptop manufacturers don't allow installing of drivers other than the ones that they provided. You'll have to mod ATI/AMD's drivers to "force" it to install in your laptop.

Download the latest drivers for your ATI/AMD card here: http://support.amd.com/us/gpudownload/Pages/index.aspx

Then use Mobility Modder, to modify the driver to work with your laptop.

  • tried all these.. it just doesn't seem to work with my ATi Radeon HD 2300 and the latest drivers that I mod.. I get BSODs.. seems like its goodbye to my old gpu here.. – Irfan May 16 '12 at 6:50
  • 1
    @Power-Inside Are you using the 'legacy' drivers? If the 'legacy' or non-legacy 10.x versions don't work, try modding the latest 9.x 'legacy' version. 'Legacy' drivers download links here: (Windows Vista or 7 32-bit) support.amd.com/us/gpudownload/windows/Legacy/previous/Pages/… – galacticninja May 16 '12 at 7:08
  • I just tried the legacy drivers.. 8.10, 9.11, 10.2, none of these install (both unmodded and modded) – Irfan May 31 '12 at 11:58
0

Modded driver for ATI (Mobility) Radeon HD2300 and X2300 cards with catalyst.

AMD_Catalyst_13.5_Beta2_32&64bit(HD_2300,x2300).7z

Windows 7 32/64 and Windows 8 32/64 Support

Description: http://forums.guru3d.com/showthread.php?p=4606224#post4606224

  • Please don't recommend the use of 3 year old modified drivers. – DavidPostill Apr 22 '16 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.