I have a PS/2 keyboard, and a PS/2 mouse - I'm using an Ubuntu/Win7 (x86) combo. Yesterday I replaced the keyboard with a new USB one. Until a restart everything was fine, but after it, the cursor couldn't be moved. I opened the device manager, and it displayed Code 10 - This device will not start.

If I place my PS/2 keyboard back, restart, then the mouse will work fine. I tried the USB keyboard, PS/2 mouse combo in Ubuntu, and it works there - so it is a Windows-only problem. I downloaded the mouse's driver (it's a Netscroll 200 Laser) - nothing changed.

Please help me! Thanks!

  • 1
    I'm using USB keyboard + PS/2 mouse on Windows without any problems. So it is likely related to hardware, so please specify what MoBo and keyboard you are using – aland Dec 28 '11 at 17:27
  • Title says "PS/2 mouse", first line says just "mouse", then you mention a "PS/2 combo", but finally you specify that the mouse is a "Netscroll 200 Laser USB". So is the mouse PS/2 or USB? – sawdust Dec 29 '11 at 2:46
  • Sorry, it was just a Google search result copyed there. It's fixed now. – antivirtel Dec 29 '11 at 9:49
  • @aland, it is a Asus M2N-X motherboard and a Chicony KU-0420 USB keyboard (this is the new). – antivirtel Dec 29 '11 at 9:58

I have the same problem, you can try to find a model close to the mouse you have, and test those drivers, or if you can find a more generic driver, that will help as well. I would also suggest you uninstall the PS/2 mouse driver in Device Manager with the keyboard and restart the computer to reinstall it to check the result. If it does not work, please also try to update the BIOS and the motherboard chipset drivers to test the issue. If it still cannot work, you may check the mouse/keyboard and USB settings in BIOS. he chipset for the motherboard is not entirely supported for Windows 7.

Also you can try the Vista chipset drivers.

Under the PCIPnP tab, set Plug&Play O\S to yes. Under the Boot tab, set PS\2 mouse support to enabled, rather than auto. Save and exit.

did you check to see if that motherboard is fully supported by Windows 7?

  • Thank you! I've tried the settings in BIOS first, nothing changed. After it, I updated the BIOS, and it is now works. Thank you! – antivirtel Dec 29 '11 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.