4

Upgrading from Firefox 8 to Firefox 9 on Linux (Ubuntu Lucid) broke a feature I use often: Running multiple instances, then aiming command line Firefox at a specific running instance.

Any ideas on how to fix or work around this?

I run two Firefox instances with separate profiles:

firefox -no-remote -P personal
firefox -no-remote -P work

(The -no-remote is necessary for the second to start a new instance, and not just a new window in the first instance.)

I then use this to open a URL in one of the running instances:

firefox -P personal http://asdf.com

This worked through Firefox 8, but in 9, I instead get the error message

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.

Same with these variations:

firefox -P personal -new-tab http://asdf.com
firefox -P personal -new-window http://asdf.com
firefox -P personal -remote "openURL(http://asdf.com,new-tab)"

It looks like the initial -no-remote flag changed in Firefox 9 to also prevent connections from future command lines. If I start an instance without -no-remote, I can successfully open a tab in it from the command line, but I can't start a second instance that way, so that doesn't help much.

2

jed davis posted a patch that fixes this by splitting a -new-instance flag out of -no-remote. hopefully it will land in an upcoming firefox release.

  • Seems to have landed. – Erika Sep 21 '13 at 10:38
  • hi @ryan, can you please write me some steps to follow to open my second profile called "Dev". Right now i am doing 1) open my default profile 2) launch dev profile with firefox.exe -P Dev -no-remote this works, but if i then do 3) `firefox.exe -P Dev -new-tab "about:blank" it wont open the new tab in it, it opens in the default :( – Noitidart Feb 8 '15 at 12:30
  • Oh im using Windows – Noitidart Feb 9 '15 at 2:25
  • @Noitidart good question! i'm not sure how to target different windows via the command line, especially on windows. sorry. – ryan Feb 9 '15 at 16:28
  • Thanks @ryan for the reply, I'll dig around in the buzilla topics linked, thanks for your effort on this. :) bugzilla.mozilla.org/show_bug.cgi?id=716110#c33 – Noitidart Feb 9 '15 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.