8

How to setup custom keyboard shortcut to launch terminal on KUbuntu?

PS. I have tried setting up shortcut that would issue xterm command, but that shows raw terminal, that looks a lot differently from the one that can be opened from the menu.

Thanks!

  • Did any of the answers solve your problem? – Ivo Flipse Jul 15 '12 at 11:38
17

I didn't have CTRL+ALT+T by default after a fresh install of Kubuntu 12.04

Here's how I assigned in.. right-click the Kickoff Application launcher icon -> Edit Applications -> System -> Konsole -> Advanced Tab -> Current Shortcut Key

| improve this answer | |
  • 3
    The "Kickoff Application Launcher" is the blue "K" button icon usually at the far left of the "Panel" bar usually at the bottom of the screen. For ex-Windoze users, it's the "start button". – Rhubbarb May 27 '14 at 22:05
1

The one from the menu is called "Konsole" so use whatever keybinding you have for the quick launcher and then type Konsole and it will come up as a choice and you are good to go.

Screenshot of Konsole/Terminal in KDE quicklauncher

| improve this answer | |
1

Ctrl+Alt+t opens a konsole window.

| improve this answer | |
  • 8
    I have Kubuntu and this doesn't work for me. – Mien Nov 7 '12 at 13:04
  • 2
    This is not a default mapping in Kubuntu! – skrtbhtngr Nov 1 '16 at 12:59
  • Hmm, I wonder how I had that? I don't remember changing it. – user114447 Nov 2 '16 at 0:01
1

I am running Kubuntu 18.04 with Plasma version 5.12.7, and the keyboard shortcut for terminal is switched off by default.

I didn't use KDE menu editor solution as I got a conflict warning message when I tried to edit the 'Current shortcut key'. It said "The shortcut 'Ctrl+Alt+T' conflicts with the following combination: Shortcut 'Ctrl+Alt+T' in Application KDE Daemon for action Run Konsole"

Made me think there's already a setting somewhere that is switched off, which I eventually found going through System Settings. (click launcher button, start typing system (for System Settings) click the link when it appears) to launch System Settings.

In the left panel menu, open 'Shortcuts', under the Workspace category, open 'Custom Shortcuts'

in the next panel, activate 'Example' button (it's greyed out by default - see the comments tab once 'Example' is selected)

Now you can click 'Example' to open sub menu drop down, Activate "Run Konsole" button Click apply and close out of the screen. Now Ctrl+Alt+T works. Shutdown and restarted just in case - Still works.

| improve this answer | |
1

I've got the same problem and I found it:

enter image description here

| improve this answer | |
0

Do it like Samer with these options u can see from these screenshots below

here

and in the advanced tab:

Image

| improve this answer | |
  • Can you explain in details not just a Link? – yass Apr 2 '17 at 14:49
  • Sorry, i will edit my answer soon. – aweber Apr 3 '17 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.