I have set up Windows 7 Ultimate 64-bit on my PC. I have 8GB RAM and my BIOS states the correct amount (8192MB), but Windows (System Manager) says I have 8.00GB (3.22GB usable). give me a solution. I'm tried this:

Run > MSCONFIG, open the Boot tab > click Advanced Options > make sure that Maximum Memory

but this wasn't helpful.

My Motherboard Details:

CPU Type : DualCore Intel Pentium, 3000 MHz (15 x 200)
Motherboard Name : Foxconn G41MXE
Motherboard Chipset : Intel Eaglelake G41
System Memory : 3296 MB (DDR3-1333 DDR3 SDRAM)

DIMM1: Kingston : 4 GB DDR3-1333 DDR3
DIMM3: Kingston : 4 GB DDR3-1333 DDR3

My BIOS Details:

BIOS Type : AMI (03/21/11)
Vendor : American Megatrends Inc.
Version : 080015
Capabilities : Flash BIOS, Shadow BIOS, Selectable Boot, EDD, BBS

System Properties :

enter image description here

Bios File :

enter image description here

What about Bios Update?

  • 2
    Can you add a screenshot of your system properties (Control Panel -> System) to your post? – Darth Android Dec 29 '11 at 20:09
  • 1
    Perhaps instead of listing what your BIOS can support, how about a list of the ACTUAL hardware involved? :) – Ƭᴇcʜιᴇ007 Dec 29 '11 at 20:29
  • are you using an original cd, some fake cd's parade as 64 but are really 32.. and allot of fakes look real..even activate..but months later de-activate.. but.. unless the motherboard has a memory hole, shows 8gb but reports less.. did you update bios? – Piotr Kula Dec 29 '11 at 20:30
  • It is also entirely possible that with 4 DIMM slots then the maximum each slot supports is 2GB, meaning that potentially only half of each of your sticks is being used... – Mokubai Dec 29 '11 at 20:46
  • Take a screenshot of the Resource Monitor, Memory tab. – Braiam Jan 21 '15 at 3:39

Enter the BIOS and go to Advanced Chipset Features → North Bridge Configuration, then change the setting Memory Remap Feature to [Enabled].

From the manual:

Memory Remap Feature

This item is used to enable/disable memory remap feature. Its mainly for if you have a 64bit OS and 4GB of RAM. Basically it allows you to remap the overlapped PCI memory above the total physical memory.

If that alone doesn't help, download the latest BIOS update from here and follow the steps outlined in the tutorial How to flash BIOS?.


I too had a similar problem to this when I upgraded my pc from 2 x 2GB to 2 x 4GB and had a similar setup; Windows 7 64 bit, American Megatrends BIOS. Tried all the software solutions proposed in the answers but no joy.

For me the problem was that one of the memory chips hadn't been pushed in with sufficient force (I have the strength of a little wood nymph).


You may need to find and enable "memory remapping" in your motherboard's BIOS/CMOS settings. Also, did you completely disable the Maximum Memory setting?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.