12

I've been having a really annoying problem with explorer in Windows 7. Sometimes I need to restart explorer, for example to help testing software I'm developing.

I know I can stop explorer.exe (either through the task manager or through the Ctrl-Shift-Right Click on menu / Exit Explorer thing) and restart it through the task manager. That used to work just fine on XP. But on my Windows 7 box it just pops up a file browsing window. No taskbar, no start menu, no desktop.

Of course I can logout or restart to get the taskbar back, but that gets annoying really fast.

Any clues to what's going on here? Is something preventing explorer from restarting the taskbar? What's the mechanism used by explorer to determine whether it should do so?

[Update] I'm not looking for alternative ways to restart explorer. I found plenty of those while Googling for a solution to my problem. I need to know why explorer is not restoring my desktop icons and taskbar after it is restarted.

5
  • Press > Windows + R and enter > explorer.exe
    – Daniel
    Dec 30, 2011 at 11:49
  • 4
    No, that does not work. Windows + R only works when explorer is already running. Dec 30, 2011 at 13:15
  • 1
    Make sure all explorer.exe processes for your user are killed before you restart it
    – mavhc
    Dec 30, 2011 at 13:38
  • Thanks, I tried that but it doesn't help. Dec 30, 2011 at 13:46
  • 1
    Did you end up finding a working solution?
    – Ivo Flipse
    Jul 15, 2012 at 11:33

5 Answers 5

14

Just had the same problem. It seems that when you run explorer.exe without full path it starts as C:\windows\explorer.exe /factory,{682159d9-c321-47ca-b3f1-30e36b2ec8b9} -Embedding, as you see, with parameters.

The solution I found, is to specify full path to C:\Windows\explorer.exe. This should run explorer without parameters. And starts Windows Taskbar.

And I really don't know, why such behaviour happens, cause before it worked fine without full path.

3
  • "And I really don't know, why such behaviour happens, cause before it worked fine without full path." -> the same happened to me. Have you found some cause(s) for it since you wrote the answer? Jan 14, 2018 at 5:24
  • That GUID doesn't works today. Any tip about how to search for the current GUID?
    – NetVicious
    Jun 1, 2021 at 13:19
  • That is kooky. Thanks, it solved my problem. Idk why full path is a different behavior. Aug 24, 2021 at 6:48
2

Press Ctrl + Shift + ESC. Go into Processes and stop Explorer.exe, as you already described. Then go to Applications --> New Task, type in explorer and press Enter.

That should work, if not try and go to Google. Search for explorer.exe and replace it. Good luck!

2
2

I had the same problem, and thanks to the answer by Jens Erat, I was able to find another solution! I've been repairing computers for years and have not seen this problem. Unfortunately, Jens' answer was not what did it for me, but while I was in that part of the registry, I saw a problem with the userinit key. The key had "c:\windows\system32\Userinit.exe."

The answer was to simply delete the extraneous period at the end of the path and start explorer again. Solved. Such a nice fix. I wonder how it ever got messed up in the first place. MalwareBytes did detect 50+ objects, however, which may have had something to do with it.

Anyways - a haiku for everyone to enjoy:

Yesterday it worked.
Today it is not working.
Windows is like that.

1
  1. Press ctrl+shift+esc to open task manager
  2. Click new task and type regedit and press enter
  3. In registry editor, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
  4. Beside the string value Shell the value data should be explorer.exe. Any value other than that can cause this error.
1
  • No idea how and why, but on my WIndows server, the entry was changed to something like "powershell.exe -noexit". You saved my day!
    – Marcus K.
    Apr 6, 2021 at 8:50
-1

I did not want to logout or restart and attempting to launch explorer via new task was not working despite all processes being terminated. The solution for me was to browse to the Windows Directory (C:\Windows) and right click on explorer.exe - run as administrator. ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.