I use a Windows 7 machine to share my internet connection, but the one network interface which are connected to my local network is marked as "Unidentified network", the sharing works well anyway but because the interface can't be chosen as Home network i can't use the HomeGroup features etc.

Do you know which requirements an interface has meet to identify a network in Windows 7?


Networks are identified according to the MAC address of the router. So if you have no gateway defined, this causes a problem. You need a gateway address to be set in your TCP/IP settings, or if you are getting these by DHCP ("Automatic") then you need to make sure the DHCP server is giving out the correct gateway IP.

Note: if you are on a wireless network, your network location has nothing to do with the SSID (network name) or the IP or MAC of the access point, but of the router. In an integrated wireless/wired/router device, this may have several MAC addresses for the different interfaces, but should tell Windows the right one for the router, so you can connect through wired or wireless and have it recognise that you are on the same network.


I found a workaround here:


Remove the // lines as they are not the right way to comment lines in PowerShell and will spew out a ton of errors. If you want, replace them with # to make it right.

Adding the default gateway as suggested by TargeT-San is the easier method.


As I read from one forum, there's just one thing for Win7 to identify network - presence of default gateway. It can be achieved by static define or by tricks with external DHCP server installed on your PC (since Win7 hasn't one). I assume it's a crude logical error in Network Manager since: a) in small home networks where one PC servers to others as a gateway to provider, ICS via NAT is selected. b) in this case, this PC becomes default gateway for others and has only one gateway - provider's one. Provider network should be Public, but local one is Home. c) this is unreachable since stupidish lock which prevents changing settings for unidentified network or identifying it manually. Also, group policies which allow this are present but they don't work. Someone, please send feedback about this to MS. P.S: What's so special with those homegroups? They work only in Home locations and with Win7 PCs. My second PC in local network is WinXP, so homegroups are just a junk for me.

  • Hamachi has this problem as well, and this is how it is fixed to give you an idea: community.logmein.com/logmein/board/… – Joseph Nov 10 '09 at 11:37
  • 1
    In case the forum post goes away: It states that manually setting a default gateway of with an interface metric of 9000 on the Hamachi interface fixes the "Unidentified Network" problem (it does for me). Hamachi versions prior to v2 did this automatically, now you have to do it yourself. – Tomalak Mar 12 '11 at 8:46

See this blog from the Engineering Windows 7 team at Microsoft: At Home with HomeGroup in Windows 7, this explains how the Home categorization came about and works. This says that the type of network isn't down to which adaptor you're using (after all both the wired and wireless adaptors on a laptop can connect to work, public and home networks), but its down to the NLA (Network Location Awareness) feature in Win 7, presumably keying off things like IP address range, (lack of) domain presence, router identities, etc.

As well this articles explaining how to join Windows 7 home groups: Neowin Windows 7 HomeGroup Overview, which suggests that what you're looking for is in the Network and Sharing Center, and called "Chose homegroup and sharing options", or type "homegroup" in the start menu.


Check under the Wireless Connection Properties->highlight Internet Protocol Version 4 (TCPIP/IPv4). Click on Properties and make sure it's set to 'Obtain an IP address Automatically. I had a similar problem when working on another wireless network with my laptop and then attempted to connect to my wireless at home. Somehow this was changed.....


I had the same problems and after a week of reading and trying I finally found out that the mobo was broken somehow. After I replaced the motherboard everything worked back to normal.


Going static seems to resolve it for me.

Don't use DHCP. Define your IP, subnet mask, DNS and default gateway manually in your network properties, and reserve it in your router.


This was problem for me tonight. I just changed my gateway to a newer model and my wife's PC wouldn't connect. After looking around I saw something about the adapter properties, specifically the speed and duplex settings. When I turned those settings off of Auto Negotiate and went to 10mbps then it worked fine. Thinking back, I had the same problems with my PC since it used a newer card, it took a longer time to negotiate the proper speed. Anyhow, check those, it might work for you.


Ok, this is how i solved it: Set your netmask to, your default gateway to your own ip as well for your primary dns server.

  • 1
    I'm sorry, but that's not possible. is not a valid netmask: it's not contiguous. Windows shows an error (and rightfully so) when I try to set it. Windows does not let met set the default gateway to my own IP either. By the way, if you manage to find a solution, I would BE very interested: serverfault.com/questions/60794/… – Etienne Dechamps Sep 7 '09 at 23:13
  • Strike my last... it worked! I have no idea why it didn't let me set the default gateway the first time, but now it worked. You don't need to put a netmask (which is still wrong, by the way) or DNS server: just the gateway works. What's strange now is that now I have an identified network AND a an unidentified network both associated with the adapter... do you have it too? – Etienne Dechamps Sep 7 '09 at 23:21
  • Okay, seems like I claimed victory a little too fast on this one. When I disable / enable the connection (or if I reboot), my default gateway is gone... seems like Windows really doesn't like having its own IP as gateway. Is there a way to make it persistent? – Etienne Dechamps Sep 7 '09 at 23:28
  • Well if you acknowledge that this answer is wrong can you please remove it? – Josh Hunt Sep 8 '09 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.