149

Whenever I click Alt + Arrow up/Arrow down my screen will do an unwanted flip. I'd like to disable this shortcut behaviour. I've already looked at Super User question How to stop my laptop's screen from rotating when I press Alt + Arrow?.

But Ctrl + Alt + F12 doesn't start any menu for me. How can I fix this problem?

I have an Nvidia graphic card, 2100M, and Windows 7 on a Toshiba computer.

3
  • 1
    One of the worst shortcuts ever, which is confusing so many users who hit those keys accidentially and do not know how to get back to the default view.
    – Avatar
    Feb 7 '20 at 10:28
  • 2
    One of the most accessible shortcuts assigned to the least used feature. When was the last time you needed to rotate your screen on Laptop/Desktop?
    – jerrymouse
    Jun 25 '20 at 19:28
  • @jerrymouse Well don't you just love to sit and play a game and make it harder by rotating the screen while you play >_<
    – Warpzit
    Jun 26 '20 at 7:58
218

Neither of these answers helped me. What I did:

Right-click on Desktop and select Graphics options > hotkeys > Disable

As indicated in Windows Forums and Microsoft Answers

8
  • 1
    I needed to assign other hotkeys in the Intel Graphics options dialog.
    – remipod
    Jun 1 '15 at 8:52
  • 1
    Note to future readers: This does not seem to interfere with Windows shortcuts as I was fearing it might.
    – emragins
    Dec 8 '15 at 17:38
  • remipod is correct (see also Noxoreos's answer): You need to assign different shortcuts in the Intel thing, otherwise it still intercepts the keypresses and other programs can't use them.
    – Timmmm
    Apr 22 '16 at 7:22
  • 2
    Worked on Windows 8.1 👍
    – Eido95
    Oct 24 '16 at 8:02
  • 8
    still works in Windows 10 Oct 25 '16 at 19:14
79

For these using Intel Graphic, to disable global hotkeys:

  • Right click on your Desktop and select:

enter image description here

2
  • Normally, I am able to access the Intel Graphics from the system tray, but it was disabled for some reason. I was trying to raise and lower the volume on WinAmp, but it kept flipping the screen!
    – Sun
    Sep 22 '14 at 15:20
  • thx @dario , upvoted for saving my day :) May 1 '19 at 7:05
11

I had the exact same issue on an Acer notebook with an Intel graphics driver. Simply disabling the feature was not enough, since the keys are still captured and not passed to the system afterwards, even if the rotation did not happen.

That means I was still not able to use this key combination in any other software, because it won't receive the shortcut.

To solve this I opened the Intel graphics properties page, enabled shortcuts, changed all available shortcuts from Ctrl+Alt+(some key) to Ctrl+Shift+(some key), and finally deactivated it again. This way the Ctrl+Alt combination is captured only for the F8 key, which can't be changed, and all other shortcuts are captured by the software I wanted to use (like Eclipse or PHPStorm) - I rarely use the other combination, so this was a valid solution for me.

1
  • Perfect. I needed to do this to enable the ctrl+alt+<- and ctrl+alt+-> shortcuts for changing tab in RStudio.
    – jbaums
    Jan 19 '15 at 0:36
6
  1. Press Ctrl + Alt + F12
  2. Click on "Options and Support"
  3. You can now either disable the hotkeys or change the keys.
0
5

Have a look at the Control Panel for the Nvidia Desktop Software and launch it. It should bring up a configuration Menu (for screen resolution, etc.) and there should be a Menu Item to disable the Hotkeys. IIRC it is the last Item.

2
  • Will try to look at work tommorow, I've looked before but couldn't find it. Its a mobile graphic card NVS 2100M.
    – Warpzit
    Jan 3 '12 at 13:08
  • 1
    I really can't find it. I've looked inside the nvidia control panel under display -> change resolution and display -> rotate display.
    – Warpzit
    Jan 4 '12 at 8:41
4

In some obscure place off the internet I found a solution.

Run msconfig (Windows key + R), select startup and disable Toshiba 180 Degrees Rotation Utility; then, click Apply and finally OK.

4

If your processor is from Intel, one of these possibilities should work in your case:
 

  1. Right-click on your desktop background and select Graphics Options > Hot Keys > Disable as illustrated in dario's answer.
     

  2. Press Ctrl + Alt + F12 to open an Intel dialog box and disable the Hot Keys. You may have to change the shortcuts before disabling them as explained in the Noxoreos' answer. Panneau de configuration graphique et média Intel
     

  3. Temporary stop process hkcmd using Task manager (Ctrl + Shift + Esc) as proposed in the gavenkoa's answer. You may also stop the process igfxTray as suggested by gavenkoa. But on next reboot, this (these) process(es) will start again.
     

  4. Disable the starting of hkcmd (and igfxTray):

    • WinKey + R
    • enter msconfig
    • go to tab Startup
    • uncheck C:\windows\system32\hkcmd.exe
    • (and also uncheck igfxtray.exe).

Window of msconfig.exe

1

It is possible to disable hot key catching by Intel applet (by Ctrl+Alt+F12 or from Graphic options on Desktop right click).

But I recommend to disable Intel applets!

Ctrl+Shift+Esc to start Task Manager and disable everything published Intel in Startup tab (hkcmd module is responsible for catching keys, also igfxTray module is useless).

1

To free up the CtrlAltArrow shortcuts for VS Code's multiple cursors

  1. Press CtrlAltF12 to open the Intel Graphics hotkeys window

  2. Click inside the hotkey fields and press CtrlAltNEWLETTER to reassign each one. I recommend using the letters D I S A B L E to make it clear to your future self that you deliberately disabled the functionality:

enter image description here

Click Apply.

  1. Uncheck the Enable checkbox to disable the hotkeys entirely. Click Apply.

You should now be able to trigger VS Code's multiple cursors using CtrlAltUp/Down (and anything else that requires CtrlAltArrow combinations).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.