When I type in admin console command to start hostednetwork netsh wlan start hostednetwork it gives me this: The hosted network couldn't be started. The group or resource is not in the correct state to perform the requested operation.

There is a hotfix from Microsoft but it didn't help me. Any advice?

C:\Users\Pirozek>netsh wlan show driver

Interface name: Wireless Network Connection 3

    Driver                    : D-Link AirPlus DWL-G520 Wireless PCI Adapter(rev
    Vendor                    : Atheros Communications Inc.
    Provider                  : Atheros Communications Inc.
    Date                      : 8.7.2009
    Version                   :
    INF file                  : C:\Windows\INF\oem108.inf
    Files                     : 2 total
    Type                      : Native Wi-Fi Driver
    Radio types supported     : 802.11b 802.11g
    FIPS 140-2 mode supported : Yes
    Hosted network supported  : Yes
    Authentication and cipher supported in infrastructure mode:
                                Open            None
                                Open            WEP-40bit
                                Shared          WEP-40bit
                                Open            WEP-104bit
                                Shared          WEP-104bit
                                Open            WEP
                                Shared          WEP
                                WPA-Enterprise  TKIP
                                WPA-Personal    TKIP
                                WPA2-Enterprise TKIP
                                WPA2-Personal   TKIP
                                Vendor defined  TKIP
                                WPA2-Enterprise Vendor defined
                                Vendor defined  Vendor defined
                                WPA-Enterprise  CCMP
                                WPA-Personal    CCMP
                                WPA2-Enterprise CCMP
                                Vendor defined  CCMP
                                WPA2-Enterprise Vendor defined
                                Vendor defined  Vendor defined
                                WPA2-Personal   CCMP
    Authentication and cipher supported in ad-hoc mode:
                                Open            None
                                Open            WEP-40bit
                                Open            WEP-104bit
                                Open            WEP
                                WPA2-Personal   CCMP
  • 1
    Before you go on bug hunting. It is also important to check if 'NETSH WLAN SHOW DRIVER says: "... Hosted network supported : Yes..." as it is shown here.
    – Nadu
    Sep 22, 2016 at 12:58

6 Answers 6


Had the same problem. Tried everything - updating Intel 5100 Wifi drivers, updating Windows 7, uninstalled and reinstalled devices and so on.

It turned out that the Microsoft Virtual WiFi Miniport Adapter wasn't working.

To make sure it's working do the following:

  1. Open an elevated Command Prompt window
  2. Type: netsh wlan set hostednetwork mode=allow

I have had the same issue recently on Windows 8 and had to reset the interface by uninstalling and then reinstalling it from the device manager.


Uninstalling the wireless adapter, then reinstalling the driver for the adapter, reinstated the ability to start the virtual adapter. However, i now have the same problem as many others - no internet connectivity from the peripheral device. Despite the ubiquity of this problem, it is fascinating that there is no simple/obvious solution. any help appreciated.

  • Uninstalling the adapter solved it here too, the microsoft virtual wifi seems to be saving regitry changes to the adapter it is virtualising, uninstall (at least) set it back to normal. For the internet connectivity you have to adjust the sharing properties on the "Internet adapter" to share the internet, and to select the "virtual wifi" to be the "Home network connection". It could be limiting it the connections to only TCP/IPv4 protocols could help, but it was not required here.
    – Psycogeek
    Apr 9, 2015 at 16:29

Assuming you are trying to create a virtual WiFi, or a SoftAP...

You will get this message in a few cases; two of the biggest:

  • You have another WiFi entwork setup with the same SSID.
  • Your WiFi card or driver does not support it:

This feature requires that a Hosted Network capable wireless adapter is installed in the local computer. The driver for the wireless adapter must implement the wireless LAN device driver model defined by Microsoft for use on Windows 7. To receive the Windows 7 logo, a wireless driver must implement the wireless Hosted Network feature.

If your hardware supports being a SoftAP, then ensure you've updated it's driver to the latest.

If you can provide more information about your hardware and network setup we may be able to help determine further.

  • Updated original post with netsh wlan drivers
    – Pirozek
    Jan 2, 2012 at 23:22
  • hi. I tried with different SSID , but still i get the same error. My driver supports it. this i know. What can be other reasons?
    – Sandeep
    Aug 7, 2012 at 3:45
  • @techie007, i have a supported adapter and i see a virtual wirelss adapter with the name: "Microsoft Virtual WiFi Miniport Adapter" but still i am facing the same problem, what should i do to make it work??
    – Johnydep
    Oct 13, 2012 at 18:36
  • @Johnydep I fixed this for me by updating the wifi driver to the latest version (an intel device).
    – ott--
    May 28, 2013 at 13:29

I think you should this:

  1. go to network and setting.
  2. go to adapter setting.
  3. right click on you WIFI adapter and disable it.
  4. right click again and enable it.

This might solve your problem.


Try this to easy the process and surpass all dificulties
A simple and easy way to manage hosted network on windows
Windows 8 hostednetwork and ICS issue, no internet access

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .