Windows 7 was pre-installed on my machine. Ubuntu 11.10 doesn't boot after I installed it. Once Ubuntu finished its installation, I restarted.

After that, it just boots straight to Windows 7, no sign on Ubuntu at all.

  • 1
    It seems Grub installation is not correctly finished. If you watched the installation, did you see any error message?
    – Sencer H.
    Jan 4, 2012 at 12:02
  • No installation went through fine. I have watch it every move. Dont kniw why.
    – James1
    Jan 4, 2012 at 20:31

2 Answers 2


If there was no error while installing then you can re-install your GRUB as follows:

  1. First, boot from a live CD
  2. Second, open your terminal and write sudo fdisk -l to see all your partitions and exact name of your linux one (sdxy) where x means the hard number (a,b,c,...) and y the number of partition (1,2,3,4,...)
  3. Third, after that you should write these following instructions:
  4. sudo mkdir /media/root
  5. sudo mount /dev/sdxy /media/root
  6. sudo grub-install --root-directory=/media/root /dev/sdx (without y number!)
  7. sudo update-grub

See also: Recovering Ubuntu After Installing Windows

  • i have followed all your steps but at the end of your steps where it says "sudo update-grub" it gave me error. Here is an error: cannot find a device for / ( its / dev mounted?)what should i do now plez?
    – James1
    Jan 4, 2012 at 20:27
  • well, have you checked that in the 6th step you wrote at the end of line (sda);where "a -or even- b -or- c" is your entire hard ?? if so then you could try write in step 7 "sudo update-grub2"
    – wisdom
    Jan 4, 2012 at 23:52
  • Thank you! I ran into the same problem this weekend when I bought an Acer Aspire V5 531 with Win7 preinstalled, and tried to get Ubuntu 12.04 LTS installed via bootable USB stick. Experienced the same error report at step 7, but it worked nevertheless. Jul 23, 2012 at 11:42

Something likely failed with the Grub installation.

There are multiple ways to tackle this.. but ill give you the short one

  • boot the Ubuntu live disk
  • mount your root directory(the partition you installed ubuntu on)
    • this can be done commandline or through the file browser
  • then use:

    sudo grub-install /dev/DRIVE

DRIVE is the drive first starts as selected in the BIOS.. usually this is /dev/sda

  • i have wrote that code and it gave me error as well, here is what error said: cannot find a device for /boot/grub (is/dev mounted?). What should i do now plez?
    – James1
    Jan 4, 2012 at 20:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .