I just got a new PSU to replace my old one that smoked itself out. My system specs are as follows:

AMD Phenom II X4 810
2GB memory
Pretty standard Gigabyte MB
CD drive
WD Caviar Blue HDD
Sapphire Radeon HD 4890
Corsair TX650M PSU

I previously had a 700W OCZ StealthXStream.

Here's the current situation:

A little while ago, the OCZ PSU burnt itself out. I quickly turned the machine off and unplugged everything, then checked the system sans graphics card with my old Antec Earthwatts (using onboard graphics, since the Earthwatts is 430W and can't power my graphics card). The system booted fine. I received my Corsair PSU a couple nights ago, and put everything back together and powered it up. The graphics card fan spun up to max speed and just stayed there, and there was no video output from it. There is video output from the onboard graphics, and the system boots fine but Windows doesn't detect the Sapphire card.

I then re-seated the card and re-plugged the power cables into the card and PSU, and voila! everything worked! Video came out of the Sapphire card and Windows detected the Radeon HD 4800 series card.

Fast forward to the next night when I get home, and when I turn the computer on now, it's gone back to its former state of graphics card fan spinning all the way up, with video out coming only from my onboard graphics. I've tried re-plugging things in to no avail. What I don't understand is why it would have worked once the previous night and stopped working now. I can provide more exact specs to my system if needed.

And while I'm here, is there any way to test the power supply and make sure that the 6-pin PCIe connectors are supplying the right amount of power using a voltmeter?

TL;DR: Graphics card fan spins at max speed when system powers on, video only comes out of onboard graphics.

UPDATE: So, I've tested my GPU in friend's computer; works perfectly. I then tested his GPU in my computer (they're not the same card, but I just wanted to make sure that my motherboard PCIe slot wasn't fried) and lo and behold, it worked! I then plugged my GPU back into my system, and it worked! This was with the HDD and front USB/IEEE/audio connectors disconnected. I then went and plugged in the HDD and booted again with success. Then I plugged in the front USB and IEEE (these are the case USB/IEEE connectors into the motherboard) and it failed again.

I now can't get it to boot at all again, with the same symptoms as before. I have NO IDEA why it will boot sometimes, but then refuse to boot other times. I know my parts aren't faulty; I've probed my new PSU and tested my GPU/PCIe slots, but still it complains and won't boot up. Any help would be appreciated!

3 Answers 3


I've discovered the culprit of my system: the new PSU. Here's the lowdown:

After finding out that there appeared to be no faulty parts in my system (i.e., the GPU and mobo seemed fine), I decided to try another PSU. I went down to Fry's and picked up an Antec EA-650 Green 650W PSU. Plugged everything in and the system booted fine. Rebooted several times just to make sure everything worked, and indeed it had no problems booting again.

I believe it has something to do with the available amps on the +12V rails of each PSU. The OCZ 700W had 72A available (the PSU that worked but burnt itself out), the Corsair TX650M has 54A (the PSU that didn't work), and the new Antec has 76A (works fine). Could it be that the Corsair didn't have enough amps to power everything properly?


Your PSU should be way enough for your system, in addition to that the system should boot and show you something even without the PCI-E cable attachted to the GPU.

On some motherboards there is also a 4 Pin Molex connector on the mainboard near the PCI slots, if you have one, did you plug it in?

Did you try a BIOS Reset and check all the other cables in your system? Does your motherboard have something like a status led or is giving a beepcode?

  • I'm not hearing any beeps from the motherboard; I'll check for lights when I get home tonight. The 4-pin molex on the motherboard is plugged in (along with the 24-pin main power), but I was under the impression that that particular 4-pin was for my CPU. I'll check to see if there's anything else left unconnected, though I don't think there is. How do I do a BIOS reset? I assume I would connect the onboard graphics so I can see what's on the screen, boot into BIOS, and select some sort of reset option?
    – CoV
    Jan 5, 2012 at 18:56
  • Oh, I dont mean the CPU molex, if you look here geizhals.at/de/372831 you see the white plug just above the first PCI-E slot. For a BIOS Reset I would check your mainboard manual, it is probably described the best way there. Reseting your options in the BIOS would be a first step to try, though is not the same as a complete BIOS Reset.
    – inf
    Jan 5, 2012 at 19:19
  • It doesn't look like my motherboard has a molex for the PCIe slot. Here's a link to it: newegg.com/Product/Product.aspx?Item=N82E16813128379, and the user manual doesn't appear to say anything about extra power from the motherboard to the PCIe slot. I'll check the manual more for a full BIOS reset if it comes to that. Before that though, what exactly would a full BIOS reset do/entail?
    – CoV
    Jan 5, 2012 at 20:04
  • you dont need the molex then. A bios reset puts all the BIOS options to its standards, its like reformating your HDD. Oh and is your PC working with both PSUs without the GPU properly? If yes, the GPU may be the faulty part.
    – inf
    Jan 5, 2012 at 21:51
  • Sigh. It seems like something's wrong with the GPU. I didn't reset the BIOS, but I did a little more poking around and noticed that the GPU has three lights for power: one for the motherboard molex and one for each of the two PCIe power molexes. None of the light up, meaning it is getting the supplied power, but it's still non-functional. I don't feel like pulling the whole thing apart and reseating today, but I will do that over the weekend and see if that fixes things, unless of course you have any other suggestions? Would doing a BIOS wipe still help?
    – CoV
    Jan 6, 2012 at 4:35

Asus has a very helpful web utility to calculate what your power supply should be able to source. I entered your information as you've given it and Asus recommends 500W. Please see the below screenshot. Power Supply Requirement Calculation

Why you may be having this work intermittently, could be the order devices are powering up in your machine. Each device initially eats a ton of power when it turns on. If your power supply can't source enough power to everything when it first comes on, you can run in to this sort of problem. Most BIOSes have a setting for hard drive spin up delays to help load balance in-rush current draw like this. You may be able to use that to get your machine to more consistently function.

You could also get a power monitor device to see if your machine is indeed eating much power when you turn it on, here's one that I've used.

From your feedback to this question - it sounds more like a connector problem or a simply faulty PSU. You can get testers, such as these. Though a cheaper way of testing your PSU is to just try another one. Less sure-fire feedback, but often enough for you to pick a sane course of (re)action.

  • And indeed as bamboon has suggested, you should make sure you've completely hooked up your PSU to your motherboard - my answer assumed you'd covered that. I'm not sure it'd work at all if you hadn't anyway. Maybe connections aren't that solid and just need to be re-seated. Jan 5, 2012 at 18:00
  • Sorry if I wasn't clear, but the current PSU is a 650W Corsair that's running into the problems. The 430W PSU I mentioned is an old one that I used to test the system without the GPU. I'll see if I can go into BIOS and set up a hard drive spin up delay, though I can't imagine not having enough power with the 650W is the source of the problem. Is it possible that the modular cables on the PSU are faulty? I really, really don't want to return the PSU to Amazon for a replacement, but if that's a serious possibility, I'm willing to...
    – CoV
    Jan 5, 2012 at 19:00
  • Oh, sorry I misunderstood. Indeed, 650W should be fine. I'd certainly check all your connectors. You could ever CAREFULLY test each pin with a multimeter (for correct voltages). Do you have another PSU around you could test on, to try to be more certain which component is the culprit? Jan 5, 2012 at 19:06
  • Unfortunately, the only other PSU is that 430W Antec, which does allow the computer to boot up properly without the GPU.
    – CoV
    Jan 5, 2012 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.