14

When I work remotely and remote desktop from my WinXP machine to a Win7 box everything is fine. When I launch a virtual machine from within that Win7 box and use my mouse pointer it is invisible inside the VM. If I hover over the title bar area of the running VM my mouse pointer will turn into a hand and I can guess where my pointer is at from there but it doesnt change (into resize or a textbar for example).

  • 2
    Do you have VMware tools installed? – Dave M Feb 2 '12 at 19:50

12 Answers 12

7

Easy way to solve this weird behavior with text cursors in some editors.

In the Virtual Machine go to "Control Panel" -> "Mouse Properties" -> "Pointers" tab ->

Once there select the "Windows Black(system scheme)" profile.

As @adam0101 pointed out in comments you can select another theme like Aero.

  • This worked for me if done in the virtual machine and not the host. – ColmanJ Jul 18 '17 at 5:58
  • Which makes sense as this is VM issue. Will add this in the answer – guillem Jul 18 '17 at 8:07
  • If you're like me and don't like the Windows Black theme, you can select one you like (Aero theme, for example) and then only change the cursors that aren't showing up to the equivalent Windows Black cursor. – adam0101 Aug 24 '17 at 15:39
  • This worked for me but since I'm using multiple monitors in my workstation, when I change the mouse pointer to another monitor, the mouse pointer disappears, It is still there (click and position works ok) but the pointer is missing. Any Ideas? – Rodrirokr Feb 4 at 10:47
2

You could try to disable hardware acceleration in Windows 7, if it works in the VM.

Ensure also that VMware Tools for Windows Guests are installed.

2

Go into the advanced system properties and ensure that the "show shadows under mouse pointer" is selected.

As strange as it seems, solved my problem.

1

I too have had this problem, the only way I could find round it was to use remote desktop to remote into the virtual machine itself directly, either that or go to www.logmein.com and setup a free account and use that to login to the virtual machine directly. For some reason mouse pointers dont seem to roam very well between three locations.

One thing to try though, have you tried making your virtual machine full screen on the pc you are connecting to ?.

Another option is to use a lan enabled kvm switch, this is different to using remote desktop in that the signal for the mouse / keyboard is fed directly into the keyboard and mouse sockets on the pc at the other end instead of being virtualised by remote deskptop, so the mouse pointer would appear in the VM the same as it does when viewing it at the pc itself, they are not overly cheap though, although you can prob find a second hand one on ebay.

http://www.google.co.uk/search?sourceid=chrome&ie=UTF-8&q=lan+vpn+switch#q=lan+kvm+switch&hl=en&prmd=imvns&source=univ&tbm=shop&tbo=u&sa=X&ei=RkMpT63dGYf1-gbEv5mtBQ&sqi=2&ved=0CGsQrQQ&bav=on.2,or.r_gc.r_pw.,cf.osb&fp=4c516b9b4590be31&biw=1920&bih=1109

1

Make sure vmware tools app is installed on the VM. If that does not help, maybe try changing your remote control app and see if that helps.

1

I encountered this issue this morning on a Windows 8.1 VM. I will say this is remote access through Citrix to the Machine. To resolve it I Opened Mouse Properties > Pointer Options and selected Display pointer trails setting the distance to short to minimize the effect of the trails.

  • Does the mouse pointer still work if you turn trails off again? – DrZoo May 10 '16 at 16:31
  • No unfortunately. I did a re-install of the system after 2 weeks and it never happened again. It was upsetting the other users of the machine. – BrianC Jun 10 '16 at 15:34
1

I periodically have this issue crop up when I launch a VM and discovered I can solve it by entering and exiting unity mode.

  • 2
    Elaborate on unity mode a little further to help make this be more helpful – Pimp Juice IT Aug 9 '17 at 16:59
  • VMware Unity mode is a feature in VMware that allows a user to display applications from virtual machines on the host system desktop. – Jim Aug 10 '17 at 12:40
  • The unity mode option button is next to the full screen option button, The unity mode button becomes active when you exit full screen mode in the VM. Exit full screen mode in the VM and then click the unity mode button. The desktop will switch to unity mode. Click the VMware icon in the task bar and select exit unity and you will return to the original VM desktop with the mouse now working. – Jim Aug 10 '17 at 12:58
  • This worked for me with my Windows 10 VM. Thanks so much. This has bothered me for months. I stopped using that host (secondary workstation) because of this. Thanks a ton! – James T Snell Oct 28 '17 at 16:24
0

Try disabling "Accelerate 3D graphics" option. (Virtual Machine Settings/Hardware/Display/3D Graphics).

Disabling this option should disable direct access to GPU, remote desktop emulates a graphics card instead of using real hardware. A bug on graphics drivers (real one) may be the reason for invisible mouse pointer which may not exist on emulated graphics card drivers. Updating drivers may also solve the problem.

  • Welcome to SuperUser. Could you elaborate on this answer? Why would this work? – mtak Jun 26 '14 at 18:54
0

We have had the same problem, but specifically around not having a mouse pointed for the legal disclaimer before logging in into win 7. Once we get past that using the keyboard, the pointer appears.

The resolution for us was that the base image was set to 1920 x 1080 screen res.

This issue only occurred when we used monitors that had the same res as the session didn't do a rescale. Changing the base image to 1440 x 900, fixe the issue.

0

Go to Edit -> Preferences -> Input, for Optimize mouse for games option select Never.

Worked for me.

Source: https://communities.vmware.com/message/2449567#2449567

-1

My issue showed up when i updated my Hosts to 5.5.0 8 update 3 and then updated my client. the mouse disappeared, after countless minutes/hours trying to get the cursor back, I threw in the towel and uninstalled the client and sifting through the regisrty and folders remving any hint of vShereCleint 5.5.0.8 update 3e. I then downloaded a new installer from vmWare and installed it. Disappearing mouse curser issue is resolved.

-2

You go to System Preferences in your OS /Security&Privacy/Privacy(tab)/Accessibility(on the list)/Allow the apps below to control your computer/check WMWare Have Fun :) Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.