I have just formatted my machine and it is now running Windows 7 Pro (64 bit). I try running the web platform installer from here, and even while as administrator I get a message "This installation package could not be opened..." I have already done all my windows update. So I am not sure how to fix this now.

Things I have tried so far:

  • Running as Admin
  • Registering and unregistering Windows installer from cmd(as admin)
  • Tried installing Windows Installer 4.5 Redistributable (Will not install, so I assume it is unnecessary)
  • Adding another user account and trying installer there
  • Tried alternate download from here
  • I might have tried some other stuff... but can't remember right now :(

My error log says this

Method '_wspawnl' failed. Failure: 0x654

Failed to install the Web Platform Installer MSI. Unable to launch Web Platform Installer.

WPI 2.0 actually installs.. However it tries to download 3.X when it first runs and gives the above error. I am not even sure if I should even be asking this question here... but not sure where else to ask :) Please help (Puppy eyes)


I did try to install the rtw at microsoft.com/download/en/details.aspx?id=6164 (*new users can't post more than 2 hyperlinks lol), but that still did not work and I should emphasise that the previous versions of WPI do work, however, they prompt me to install the newer version, which fails also.

  • While this is technically a developer tool (it allows you to install some development tools), your issue appears to be related to the installer. Perhaps [SuperUser] can give you some hints about troubleshooting installer problems? Also, have you read this link? – user939 Jan 6 '12 at 14:52
  • ty for migrating here. Anyway, I scoured that forum on the first day of my problem :) I will try it again to see if I missed anything. – GatesReign Jan 6 '12 at 15:21

The operating system version or type seemed to have been the fault with me being unable to install WPI, because I formatted using another windows 7 disk and I had WPI up and running in no time.


I faced the same problem when I killed/abruptly stopped the installer.(WindowsAzureSDK.3f.3f.3fnew.exe)

  1. Downloaded and ran the Microsoft Fix It installer
  2. It will open - Program Install / Uninstall troubleshooter
  3. Select MS web platform installed from dropdwon box.
  4. select option -- Yes , un-install

This should fix your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.