I have a friend's Asus X54 L laptop that Windows 7 (64-bit) suddenly stopped loading correctly on.

Windows loads a little slowly to the login screen, I login, then it takes hours just to get to the background. The screensaver kicks in occasionally.

I can boot into safe mode just fine, but not with networking. Safe mode might be a little slow, but it is difficult to tell. Otherwise, it is usable and functional in safe mode. Safe mode with networking experiences the same slowness as a regular boot.

Would a dying HDD have symptoms like this? I have run chkdsk - all came back normal. Malwarebytes and SuperAntiSpyware quick scans in safe mode both came back clean.

I have turned off all startups in msconfig, and that didn't change anything.

I have run Windows Memory checker, and that also returned no problems.

I have run Autoruns but couldn't really see anything useful to me (not experienced with it though).

I have tried several system restores to no avail. There are 3 system restores available, 1 was automatic, 1 was related to the "Windows Module Installer", and 1 was from the "Language pack removal".

Finally, I have tried to load an Ubuntu Live CD (on my USB stick). I have done this successfully with many computers, but I get an error on this one most of the may through the loading sequence: Ubuntu Live CD Boot error


Graphics: Intel integrated graphics

CPU: Intel Core i3 2.20 GHz

Ram: 4GB

OS: Windows 7 64-bit SP1

HDD: Hitachi HTS547550A9E384

Can anyone give me some suggestions as to what the problem may be? My reading suggests HDD going bad, but I hope for the opinion of someone with some expertise.

EDIT TO ADD: I also note the BIOS will not save my boot priority settings. I have 3 times now set it to boot to USB, then CD, then HDD. It has reverted every time to the default, which is reverse of that order. No idea if it is relevant, but there it is.

EDIT 2: As per XXL below, I have added some screenshots of my S.M.A.R.T. tool. S.M.A.R.T. Health 1 S.M.A.R.T. Health 2

The two images above are the full view of the Health tab.

Disk Monitor

This image (above) shows Disk Monitor running for over 6 minutes.


This image (above) Shows the results of a benchmark test.

Random Access

The above image shows the results of a Random Access test.

I honestly don't know if these have helpful information, but this computer is not usable in it's current state. I appreciate any help I can get!

  • 1
    I suggest after looking at this thread, that you check your BIOS hard disk type settings. – user111228 Jan 7 '12 at 0:19
  • I understand that post, but my "live CD" is actually a USB stick. So I don't see how the SATA ports could affect the boot status. I'd love to get Linux up though, so I could perform the steps that XXL recommended. Also, I did check the drive settings in BIOS. the HDD is already set to AHCI. – apathos Jan 7 '12 at 4:32
  • safe mode works "ok" , please confirm, if there is anything slow when run via safe mode, other than it's slow because of being in safe? – Psycogeek Jan 7 '12 at 7:11
  • 1
    I can boot to safe mode just fine. Nothing has the prolonged, hours-long load times. Things seem to be just a little slow, but it's hard to know if it is because of safe mode, the laptop is slower than I think it should be, or if there may be a problem. – apathos Jan 7 '12 at 22:19

Would a dying HDD have symptoms like this?

Yes, it would. Did you run a bald chkdsk over the volume in question or as chkdsk /F /R? The extra /R switch is supposed to take care of bad sectors.

However, I'm not so sure of the error you're getting with busybox. Likely to be related to some other system issue.. (not triggered by your main issue). Someone more in the know will be able to address that, I bet. You could try with a different live distro, though.. and plugging directly into a native USB port, instead of a hub (if that's the setup atm). I'm out of ideas on that part :P

Anyhow, if you get a working linux session - then you can grab smartmontools pkg and inspect the drives S.M.A.R.T. attributes with smartctl -A /dev/sdX. Values (last column called raw data) in the following sections are going to be your point of interest:

#05 Reallocated Sectors Count
#197 Current Pending Sector Count

Then initiate a short self-test with:

smartctl -t short /dev/sdX

And see the results after a couple of minutes with:

smartctl -l selftest /dev/sdX
  • The switch R implies F, so chkdsk /r – Moab Jan 7 '12 at 0:46
  • When I ran chkdsk, I flagged for repair. No errors were found. I just ran HD Tune Pro to get the SMART data. #05 Reallocated Sectors Count is "ok." The Current Pending Sector Count is "ok." All statuses are given as "ok" – apathos Jan 7 '12 at 5:07
  • @apathos: hm, that's odd.. anyhow, I wouldn't trust the assessment given by hdtune with just "ok" - inspect the data column on those attributes. Can you post a screenshot of your SMART tab or an export in text? Also, it's probably a good idea to run the self-tests. – XXL Jan 7 '12 at 9:27
  • @XXL: I have added the requested screenshots to the original post. I honestly don't know if the other images capture the other info you were looking for regarding the tests. – apathos Jan 11 '12 at 1:52
up vote 1 down vote accepted

I have a solution! I had previously turned off all startups, but I had not turned off services. So I turned off all non-Microsoft services, and the laptop booted fine!

The last service in the list was the first one I turned back on, and it immediately would not boot correctly again. I turned that service off from safe mode - the laptop booted just fine again.

The offending service? "WRSVC", the service for Webroot SecureAnywhere. I have no experience with this program, but my research tells me it is at least a legitimate tool.

But that means the program only causes problems when the service is enabled. If I start the program manually after boot, it works fine. What would cause such behavior?

  • 1
    Legit, but let me say it like this. Actual real reviews of the product were not so good at all. If you notice when trying to search for the product, the search has been Spammed, overloaded, rammed, beloted. IMO you should find legitimate reviews for the actual product from reliable reviewers and users. and just expect that they will hop in here right now and negate what I just said (that bad). Look for other Names this thing was once called also. The power of the web. Mabey it is a bit new, and a new idea, but more research from REAL people would be what you should do. – Psycogeek Jan 15 '12 at 8:57

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.