10

I am trying to create a system image of my OS drive but Windows it trying to make me backup my storage drive as well showing it as a system drive: enter image description here

I only want to back up my Windows drive (C:) but the option to untick the storage drive (D:) is grayed out. I read in this post that I may have inadvertently installed a service to this drive.

The only solution I could think of was to transfer my data from the drive and format it then transfer it back, but it seems like a very long way of solving a simple problem. How can I either find that service that is making Windows think my D: drive is a system drive or another way to get Windows just to back up the C: drive.

*Please note: I'm not looking for an 3rd Party solutions, I would like to stick with Windows because I manage all my computers the same way with the Windows backup.

UPDATE: I took the advice of some of the comments and disconnect the D: drive (see picture above. - The non-Windows drive) When I went to boot back up, nothing. The computer will not boot into windows unless the D: (storage drive) is connected. I found that the boot manager is on the D: drive instead of the C: Drive: enter image description here

How do I move the Boot manager from D:\ to the C:\ drive?

2
  • 1
    If for some reason the D partition is the "boot" partition this is why you cannot de-select it, use disk management to see if D is a boot partition.
    – Moab
    Jan 9 '12 at 1:50
  • You should follow the entire advice as given by @JustAKid: You should not only disconnect D, but also do Startup Repair by booting from the Windows 7 DVD.
    – harrymc
    Jan 11 '12 at 9:07
5

I had this same problem, both the C and D drive were required when doing a Windows 7 image backup. I felt it was not necessary to include the D: drive in the image backup.

I have always used the D drive when possible when I installed software. Since I switched to a SSD using D drive became more important (120GB SSD). I found 3 services that pointed to my D drive. I switched two of the programs from the D to the C drive. The third, which is photo editing software, I had already marked as disabled. I deleted the service in the registry in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\

1
  • This worked great, I did a Ctrl-F search on E:\ under this registry path and found the offending service. I noticed under Windows 10 I needed a reboot before it worked.
    – PeterJ
    Jan 26 '17 at 3:54
2

I solved my problem but in a very long and arduous way.

After I found that Windows was booting from the D: drive by disconnecting it, I first ran cmd as Administrator and used the BCDBOOT tool. I typed:

bcdboot c:\windows /s c:

I then tired to use diskpart while in Windows to clean the drive but it wouldn't allow me too. So I booted into Windows repair section with a Win7 recovery disk (similiary to what @justakid suggested) but instead of doing the automatic fix I opened cmd in recovery mode. Oncein cmd I used diskpart to clean the D: drive of boot files by:

DiskPark
Select Disk 0 \\my D: drive
clean

I then rebooted and the D: drive was no longer a System drive.

1
  • As it is a potentially destructive command, I just want to note here that clean parameter removes any and all partition or volume formatting from the disk with focus. On master boot record (MBR) disks, only the MBR partitioning information and hidden sector information are overwritten. On GUID partition table (GPT) disks, the GPT partitioning information, including the Protective MBR, is overwritten; there is no hidden sector information. Source: technet.microsoft.com/en-us/library/cc766465%28v=ws.10%29.aspx
    – Ert
    Nov 16 '14 at 21:06
2

Had the same problem and the solution is in Windows disk management you need to temporarily set your D: drive or others to offline. Then you can configure Windows Backup for C: system image without other drives. Now backup works as expected and you can set your offline drives to online again. enter image description here

1

Sorry, but this way is very slow.

You can go to services.msc, highlight a service, and click properties. It will show the path to the executable. If it is on drive D:\ that is the service you are looking for.

4
  • 1
    Might be easier to disconnect the drive and reboot to see if you get any service errors, either popping up, or in the system logs somewhere, to help spot the possible service. Jan 9 '12 at 3:20
  • That's a good idea idea.
    – soandos
    Jan 9 '12 at 3:27
  • see updates above, I think it's almost solved.
    – Nick
    Jan 9 '12 at 21:23
  • Following this answer, the solution was to either a) move the off-drive service on-drive or b) insert a shortcut on-drive that points off-drive. shortcuts don't work in services directly, but they do wrapped in a command string C:\Windows\System32\cmd.exe /c "C:\ServiceShortcuts\ShortcutToExeOnOtherDrive.exe.lnk". I backup those drives separately from Windows image, so works for me. Jan 18 at 16:44
1
+50

You can try this:

  • Disconnect your storage device (D:).
  • Insert your Windows 7 installation disc.
  • Set the boot order so that it will check disc drive first.
  • When prompted, press any key, and wait for it to load the setup interface.
  • Choose the language and keyboard preferences.
  • Click "Repair your computer".
  • Select the Windows installation you want to repair, and then click Next.
  • On the System Recovery Options menu, click "Startup Repair".
  • Go along with the instructions and wait for it to finish.
  • Try boot again without the disc and storage device.

Source:

4
  • Will this delete the boot files on the D: drive? I have fixed the boot options so that the C: drive can boot independently of the D: but the D: drive still shows as a system drive.
    – Nick
    Jan 11 '12 at 22:22
  • It won't delete boot files on D: drive, because it is not connected to your computer; but if that disk is connected, Startup Repair would report someting like "no problems found" because it could detect boot files on D:. You can open Computer Management, navigate to Disk Management, and check the contents of "Status" of D:. If it contains something other than "Primary Partition" or "Logical Drive", then it maybe the reason of your problem. See microsoft.com/resources/documentation/windows/xp/all/proddocs/… for details on "status" column.
    – KidPooh
    Jan 12 '12 at 6:44
  • Typo: "someting" -> "something"; and according to support.microsoft.com/kb/314470, if boot files (bootmgr, boot folder, etc.) is copied to C: so that you don't need D: to boot, D: should not be considered as a "System Volume".
    – KidPooh
    Jan 12 '12 at 6:55
  • +50 for getting me to a point where I could solve my problem.
    – Nick
    Jan 13 '12 at 15:49
1

wmic service get PathName

will get the executable file for all your services so you can find if you have one thats forcing a drive to be part of the system image.

1
  • Following this answer, the solution was to either a) move the off-drive service on-drive or b) insert a shortcut on-drive that points off-drive. shortcuts don't work in services directly, but they do wrapped in a command string C:\Windows\System32\cmd.exe /c "C:\ServiceShortcuts\ShortcutToExeOnOtherDrive.exe.lnk". I backup those drives separately from Windows image, so this worked for me. Jan 18 at 16:46
0

Well, I fixed this problem really easy. So, yeah dude. At first I couldn't de-select my 'D' drive (this never happened to me before); I just wanted to image my 'C' drive only. So to fix this weird glitch I went to computer management by right-clicking on my computer and selecting "Manage", then I opened 'Disk Management', then I right-clicked the 'D' drive and clicked on ‘change drive letter’, then I removed the drive letter completely. Then I closed the "Disk Manager". Then I did a ‘dry run’ on the system image backup process, and of course I couldn't see my 'D' drive in the list of what you want to include in the image backup. I cancelled the ‘dry run’ of the image backup - and went back to ‘Disk Management’ and added the drive letter back - I added "D" again - then closed the disk manager, then I ran system image backup and it worked normally, 'D' drive was no longer force as a second system drive. Ta-Da !!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.