1

VMware one day offered an update (8.0.1 build-528992 my current version) from 8.0. I accepted it, because updates usually fix problems. However not in this case...

Previously it worked very well. Now, it still "works" but the one glitch I'm getting makes it too hard to deal with. This screenshot will explain my problem:

My glitch

As you can see, my virtual PC is not resizing correctly. (This happens with any operating system), autofit guest just doesn't work - it only results in things like this happening. Thanks to the tools it becomes very hard to NOT autofit guest.

I've tried uninstalling 8.0.1 completely and installing 8.0 again but with the same results. I don't really understand what the new update has done to VMware Workstation or to my virtual machines. I do believe this isn't VMware Workstation's direct fault but from VMware Tools, which would explain why going back to 8.0 didn't work since VMware tools has its own updates.

How can I fix this?

The host is running Windows 7 Ultimate 64-bit.

5

You need to install the video drivers for this. In the virtual machine in question, go to:

C:\Program Files\Common Files\VMware\Drivers\video_wddm\

and upgrade the video card drivers with these ones.

1
  • I am having the issue on Workstation 9, and the "wddm_video" folder does not exist in the guest. Do you know where I can download that driver? – Jay Imerman Jan 31 '14 at 20:38
2

I have the same problem since that update. If you have an existing support contract with VMware for your Workstation license (you did buy it legally, didn't you...?), you can submit a ticket describing your problem. My experience with their support is that they are absolutely relentless, and there is at least a 95% chance that the fix to your issue will appear in the next VMware Workstation update push if the developers can reproduce your problem.

My support subscription expired, so I can't submit a ticket for you. ;x However I have to say that as far as getting bugs resolved for VMware products, the best and only solution is to go directly to VMware through their official support channel, which unlike most companies is not a black hole... they treat your issue like it directly affects their bottom line. They get it fixed.

Since this question falls under "the software is not working properly" and not "the user is doing something stupid", I don't think you're going to find a viable answer on SU other than "contact VMware". Sorry.

That said, there's a workaround that occasionally works for me. Try one of two things:

  1. In the guest, go to Screen Resolution and change it to a higher screen res. Adjust repeatedly until it looks semi ok. It should allow you to change the resolution to a huge variety of possibilities because the VMware graphics driver reports that it can support almost any resolution.

  2. Reduce the size of your VMware Workstation window on the host side to be smaller than the size of the guest console... then maximize your Workstation window. Sometimes this triggers an auto-fit.

2

In my case I searchd hours for a solution and nothing worked.

My solution was that the option "stretching" was active - which disables "autofit". After disabling "stretching", "autofit" was working again....

0

If anyone still has this problem and tried the other answers without success, here's how I did it.

  1. In VMware Workstation press the VM button in the top menu, then press Reinstall VMware tools.

  2. Open up file explorer and run "DVD Drive (D:) VMware Tools"

  3. Use the Repair tool in the setup.

  4. Restart VMware

Hope this helped :)

0

A combination of the last two posts did the trick for me. After hours of trying to fix this I changed one line from "False" to "True", and then reinstalled VMware tools. I still don't have the full resolution, but at least now I can stretch the vm to full screen size.

gui.applyHostDisplayScalingToGuest = "TRUE"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.