On Windows 7 64-bit, the user is getting the following message when Windows logs in:

The program or feature \??\C:\Windows\Explorer.exe cannot start or run due to incompatibility with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available

Clicking OK give a blank screen. I can run Task Manager to launch other programs, but I can't run ANYTHING as an Administrator. When I boot off the Windows 7 CD to Repair your Computer, I can open the command prompt and run SFC /scannow /offbootdir=D: /offwindir=D:\Windows (as detected), but it fails and doesn't say what file. I tried to replace the EXPLORER.EXE file with one from my other 64 bit Windows, and the same message appears.

I have tried the KSOD fix of loading the registry remotely and checking the shell registry value, but it's set to Explorer.exe already. I have run CHKDSK /f /r from another computer on it, and from the Command Prompt in the recovery console, no bad sectors found and no repairs to be made. Western Digital Data Lifeguard says the drive checks out fine. Virus scanned on another system, no viruses found.

EDIT: Tried doing System Restore but it keeps failing with error 0x8000ffff. It gets to the Welcome screen with the spinning circle, and that's about it

  • 1
    Sounds like the Windows installation is corrupt.
    – Ramhound
    Jan 9, 2012 at 19:12
  • Sounds like 32-bit .EXE was replaced with 64-bit or Windows updade at the wrong time when drunk engineer placed 32-bit file in 64-bit repository.
    – Boris_yo
    Jan 9, 2012 at 19:18
  • Unfortunately, that doesn't help though :( If the installation was corrupt, SFC should at least tell me what to do to fix it Jan 9, 2012 at 19:20

1 Answer 1


Figured out the issue (don't think it's fixable though). The registry is corrupt. All the files are there, but when trying to load the SYSTEM hive, nothing appears. So it seems that it's not fixable (CHKDSK didn't do anything, as SFC didn't either) without a reinstall

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .