7

When applying a conditional formatting rule in Excel, using the "Edit Formatting Rule" dialog, and using "Use a formula to determine which cells to format," you cannot move the caret (text insertion point) in the formula editor with the keyboard. If you try to use the arrow keys it inserts the cell name next to the cell in focus depending whether you hit the up/down/left/right key. Is there some way to turn this off? or some way to move the caret with the keyboard?

  • It was very frustrating for me too, compounded by the facts that it is the default behavior and there is no helpful reminder in the dialog box. I almost posted a duplicate of your question. Thank you, and thanks to SE for its powerful "Similar Questions" feature. – ADTC Jul 11 '14 at 4:11
11

After you enter your formula, press F2 to enable edit mode allowing you to move the cursor with the arrow keys.

| improve this answer | |
  • 3
    Thanks! You have no idea how much that has frustrated me. – Drew Chapin Jan 10 '12 at 15:17
  • You're welcome. Glad to help. – CharlieRB Jan 10 '12 at 15:19
  • "After you enter your formula" I am in the middle of entering my formula and I can't press F2. What do I need to do? – theonlygusti Aug 17 '17 at 12:06
  • @theonlygusti Did you try it? It works for that too. – CharlieRB Aug 17 '17 at 14:11
  • @CharlieRB yes I tried it, it just plays a "boop" noise and does nothing. I'm on a mac running excel 15.27 – theonlygusti Aug 17 '17 at 14:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.