This morning my Macbook Pro (2011 model), decided it didn't want to boot, and is stuck at the grey screen. The startup chime happens, but then stays on a blank grey screen. This seems to be for no apparent reason, as both OS's were working fine yesterday. I haven't installed any updates on either OS for quite some time.

I have tried several key combinations: Option, Safe-Mode, PVRAM Reset - none seem to work. I've also tried to boot from my Snow Leopard disk that came with my Macbook, as well as trying to boot from a Recovery USB Drive created from Lion.

I have BootCamp (Windows 7 x64) and OS X Lion installed.

Any ideas?


Aside from the PRAM, there's a SMC (System Management Controller) reset. Apple doesn't describe your situation as being fixable with an SMC reset, but it does no harm to try. It's described here: https://support.apple.com/kb/ht3964

Out of curiosity, does target mode work? (Hold down T immediately after powering up.) If it does - make a backup to another system, ASAP, and we know that at least some part of EFI is working properly.

Hard drive failure could account for the problem you're seeing, if EFI is trying to read from your hard drive and can't; it'll get stuck doing so, not reading keyboard input. Power up the machine while listening with your ear against the machine. Do you hear the drive spin up? Do you hear any odd noises (such as the drive repeatedly trying to spin up), or repeated clicking?

You can:

  1. Try disconnecting the internal hard drive temporarily and trying to boot off a CD, USB key, or other external drive (verify the device is bootable on another mac if there's any doubt.)

  2. Try swapping the internal drive with a known-good drive from another Mac laptop, preferably with the same version of OS X (note that it may not successfully boot the whole way, but at least it would rule out any non-drive issues). 10.6 won't boot your system, and 10.7 might not unless it's up-to-date with system updates (very new systems ship from the factory with one-off modifications to the OS to support that particular machine if necessary, and then support is rolled into the next OS update.)

Getting to the drive involves removing all the screws on the bottom plate and two screws that hold the drive in place. It will not invalidate your warranty. If your computer is under warranty, you should take advantage of that and bring the system to an Apple store or authorized reseller for diagnostics.

It won't hurt to re-seat the memory modules while you're there, though this is unlikely to be the cause. If you have non-factory RAM installed, replace the factory RAM (or remove non-factory RAM) temporarily to eliminate it as a cause. Make sure to properly ground your body before touching anything inside, and re-ground yourself if you move (say, getting up out of a chair.) At the very least, touch the case of the laptop before touching anything internal.

You do not need to replace the bottom plate to power up the system for short periods (ie testing), but be VERY careful not to place the computer on anything conductive until you do.

If you respond with an update, I will try to update this with additional info based on the update.

| improve this answer | |
  • Hi BeeDee, sorry for posting the wrong section - didn't realize there was an Apple one! I have since swapped out the hard drive with another one, and it indeed seems to be the issue. The old hard drive was an SSD - I suppose this means the drive has died? I've only had it for about 1 year, and would have thought it should last longer than that. – crawf Jan 11 '12 at 6:18
  • You could confirm by swapping it back, into another machine, or an external USB case. SSD failures aren't unheard of; I've seen plenty a Newegg reviewer or OCZ forum commenter gripe about total failure. I'd definitely contact the manufacturer to troubleshoot or request a replacement, maybe poke around on their web forums if they have any; it might be fixed with a firmware update or tool from the manufacturer. Glad you figured out what it was (and I hope you had a recent backup!); if my post helped, would you mark it as the solution, please? – Brett Dikeman Jan 11 '12 at 6:31
  • Hmm, just tried to access it from another machine, and doesn't seem to recognize it. Attaching it externally via USB doesn't work either! I'll poke around the forums (it's a Corsair drive). Thanks so much for your help (thankfully, I've got a semi-recent backup)! – crawf Jan 11 '12 at 6:46
  • @crawf Your question is appropriate here, as Macs are computer hardware and OS X is computer software; and the decision to post on Super User or Apple.SE is entirely yours to make. Apple.SE isn't more specialized or more focused either, since they accept iPhone, iPod and iPad questions, which are off topic on this site. See this response by a diamond moderator on Meta and this post linked from there. – Daniel Beck Jan 11 '12 at 8:48

You can also try and boot from a network. When starting the computer, hold down Cmd and N and wait for the blinking globe to appear. If there is a bootable drive on the network (wired, preferrably school) it will do all the work for you.

| improve this answer | |
  • "I have tried several key combinations...none seem to work." -- I'm guessing the issue was as @BeeDee suggested... "if EFI is trying to read from your hard drive and can't; it'll get stuck doing so, not reading keyboard input" – JoshP Sep 18 '12 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.