I have a program and want to either bring its Window to the front or reopen it after it is minimised.

It is on the taskbar and hovering over it shows the preview of the window. However clicking on it does not make it reopen and become visible.

This happens with Notepad++ and Beyond Compare - both of which have tabbed panes.

Any advice on how to force the Window to reopen?

  • Another tip: If I wait a moment the program will open eventually. Oct 29, 2012 at 14:12

6 Answers 6


Try hold Windows Key + Shift then press the Left Arrowkey 2 or 3 times. If that doesn't work try again with the Right Arrowkey instead.

  • +1 @Mark Price - thanks I will check that out next time. Jan 11, 2012 at 15:19
  • 1
    This often happens when the window somehow ends up off screen in its restored state. Mark's answer will usually work, or you can right click on the preview and select "Maximize".
    – Eclipse
    Jan 11, 2012 at 16:29
  • 3
    Eclipse, It can also happen when windows thinks there is a second monitor added when in fact there isn't. The application gets stuck on the other screen so even Maximize won't help.
    – Mark Price
    Jan 12, 2012 at 17:26
  • +1 @Eclipse for the tip about the preview and "Maximise" Aug 28, 2012 at 12:36
  • 1
    Accidently, I connected both the VGA and DVI connector from the PC to the same single Monitor. Every program started minimized without a chance to maximize it. With the above shortcut it would work. Thanks to the hint from @MarkPrice I fixed my cable mistake.
    – PeterCo
    Jan 28, 2017 at 9:42

I solved the issue whereby only one icon in the taskbar won't maximize/restore:

  1. Right-click the icon to see the pop-up menu with options (close window, pin to taskbar, name of program).

  2. Click on the name of the program. This should result in the taskbar icon flashing.

  3. Press and hold Win, and browse through opened windows by pressing Tab. You should have your software maximized again. If this doesn't work, do the next step.

  4. Win+D (pressing these keys together should refresh your desktop to original positions).


I had a same problem. Actually that window had displayed a modal dialog box and that dialog box had gone out of screen. these are the steps I followed on windows 10 . Other solutions in this post didn't worked for me on windows 10.

  • Alt+Tab # displayed all window list with preview.
  • Using right and left arrow key navigated to that particular window.
  • Selected that window using enter key (At this point modal window was in focus but out of screen and wasn't visible.)
  • Alt+Spacebar - this displayed top left context menu. Only move and resize was click-able. I selected move.
  • Using arrow keys, I pulled it in mid of the screen, only dialog border was visible when I started using arrow keys.
  • Enter key to fix new position.
  • 1
    [Alt+Spacebar, Move, Arrows] did the trick or me, thanks.
    – Lodovik
    Oct 24, 2018 at 14:45
  • yes, alt+spacebar this is it!
    – lww
    Sep 11, 2021 at 21:15

Here's how I fixed the problem.

I had one WordPad document open and it was stuck minimized in the taskbar.

I tried all the other suggestions here without success.

Because I am using Windows Classic theme, I thought to switch to an Aero theme so I might at least get a hint of what was on the WordPad document by using Aero Preview.
As soon as I switched to the Aero theme the WordPad document maximized.

So, try switching themes types (Aero -> Classic) or (Classic -> Aero) and see what happens.

  1. Click on taskbar icon.
  2. Right-click on small window and select move.
  3. Use arrow keys to move the window, most likely left arrow.
  4. Locate on a visible area, press enter.

I'm having the same problem and none of the above solutions work for me, but I did make an interesting discovery that might shed some light on the issue.

This problem occurs for me whenever I run one specific game full screen, switch to windowed mode from the game, minimize, then attempt to restore.

When all attempts to solve this failed, I created a fresh new account, ran the game from there, performed the exact same steps, and the game restored just fine.

I disabled every startup app from MsConfig, but it made no difference. I have no idea why I can restore from the new/clean account but not my regular account even with every app disabled.

Something else is clearly going on.

Not the answer you're looking for? Browse other questions tagged or ask your own question.