I have a video file of 30 minutes, but I want to extract a video from 00:09:23 to 00:25:33.

I can define the startposition with -ss, but I couldn't find one for the end position. Any help please?


Install ffmpeg

Make sure you download a recent version of ffmpeg, and don't use the one that comes with your distribution (e.g. Ubuntu). Packaged versions from various distributions are often outdated and do not behave as expected.

Or compile it yourself.

How to cut a video, without re-encoding

Use this to cut video from [start] for [duration]:

ffmpeg -ss [start] -i in.mp4 -t [duration] -c copy out.mp4

Here, the options mean the following:

  • -ss specifies the start time, e.g. 00:01:23.000 or 83 (in seconds)
  • -t specifies the duration of the clip (same format).
  • Instead of -t you can also supply the end time with -to.
  • -c copy copies the first video, audio, and subtitle bitstream from the input to the output file without re-encoding them. This won't harm the quality and make the command run within seconds.

Note that if you've used -ss, you have to subtract this from the -to timestamp. For example, if you cut with -ss 3 -i in.mp4 -to 5, the output will be five seconds long.

For more info, see https://trac.ffmpeg.org/wiki/Seeking

How to cut a video, with re-encoding

If you leave out the -c copy option, ffmpeg will automatically re-encode the output video and audio according to the format you chose. For high quality video and audio, read the x264 Encoding Guide and the AAC Encoding Guide, respectively.

For example:

ffmpeg -ss [start] -i in.mp4 -t [duration] -c:v libx264 -c:a aac -strict experimental -b:a 128k out.mp4
| improve this answer | |
  • 1
    On ubuntu 12:10, -c:v and -c:a didn't work. I had to use "-acodec copy and -vcodec copy" instead. – Samuel Lampa Apr 2 '13 at 14:21
  • 1
    @Samuel Then you're using an outdated version, which isn't even real FFmpeg, but the Libav fork. See: stackoverflow.com/a/9477756/1109017 – slhck Apr 2 '13 at 14:45
  • Thanks for this! if you don't specify a duration, will it go to the end? – Jeff Mar 31 '14 at 17:03
  • @Jeff Yes! (character minimum) – slhck Apr 1 '14 at 5:34
  • 5
    @Prateek When copying the video bitstream (instead of re-encoding), you can only cut at keyframes. If there are keyframes at seconds 1, 2, and 3, but you want to cut at second 1.5, then ffmpeg will wait until second 2 before it can start cutting. That makes it inaccurate. – slhck Jul 3 '15 at 12:36

I think you can use the following command now.

ffmpeg -i inputFile -vcodec copy -acodec copy -ss 00:09:23 -to 00:25:33 outputFile

Have a look also ffmpeg Doc, or this wiki page.

| improve this answer | |
  • 8
    ffmpeg -i inputFile -c copy -ss 00:09:23 -to 00:25:33 outputFile simpler version – nwgat Nov 20 '16 at 16:37
  • 4
    I had to use ffmpeg -ss 00:01:00 -i video.mp4 -to 00:02:00 -c copy -copyts cut.mp4 version (with -copyts), otherwise it cut incorrectly (with black screen in the beginning). Thanks for the 2nd link though. – Necronomicron Jan 12 '18 at 15:51
  • 1
    This is great, the last thing I wanted was calculating the duration from endpoints. – Tomasz Gandor May 11 '18 at 9:50
  • 2
    The -to option answers the question that was actually asked. The rest of the answers are either impertinent or obsolete. – James Bowery May 15 '18 at 15:35
  • @Necronomicron but timestamps may not be appropriate with that variant. – jarno Apr 2 at 23:33

This is odd that no-one suggested the trim filter.

Drop everything except the second minute of input:

ffmpeg -i INPUT -vf trim=60:120

Keep only the first second:

ffmpeg -i INPUT -vf trim=duration=1

Drop everything except from second 13 to second 58:

ffmpeg -i INPUT -vf trim=13:58 OUTPUT
| improve this answer | |
  • 13
    Yes, good to mention trim and atrim. I usually use these when filtering, but users should note that filtering requires re-encoding. – llogan Apr 7 '15 at 17:28
  • You are my hero. I badly needed a filter that did this. – fahadash Dec 24 '16 at 5:55

You can use these two methods which work for Windows and Linux.

There are two ways how to split video files by ffmpeg. The first one is good in itself, more than that - it is faster, but sometimes creates output files with certain flaws. So for those cases there is the second way of splitting video files: it is considerably slower, the output files are bigger, but it seems they are always of the same quality level as input files used.

Way 1:

ffmpeg -ss <start> -i in1.avi -t <duration> -c copy out1.avi

Way 2:

ffmpeg -ss <start> -i in1.avi -t <duration> out1.avi
  • <start> – the beginning of the part of a video ffmpeg is to cut out. Format: 00:00:00.0000, meaning hours:minutes:seconds:milliseconds.

  • <duration> – the duration of the part of a video ffmpeg is to cut out. Same format as above.


ffmpeg -ss 01:19:00 -i in1.avi -t 00:05:00 -c copy out1.avi
ffmpeg -ss 01:19:00 -i in1.avi -t 00:05:00 out1.avi

ffmpeg cuts out a part of the video file starting from 1 hour 19 minutes 0 seconds. The duration of the video sequence cut out is 5 minutes 0 seconds.

| improve this answer | |
  • Ok, thnx. Will check out the docs and give it a try tomorrow. – juGGaKNot Oct 3 '13 at 19:18
  • 3
    -sameq does not mean "same quality" and has been removed from ffmpeg. Use -codec copy instead. Also, don't forget about the -to option. – llogan Oct 3 '13 at 20:47
  • I corrected the commands in your quote, as they were quite outdated. Please don't copy-paste information without properly quoting it. – slhck Oct 4 '13 at 10:08

You can use this

ffmpeg -sameq -ss clip_start -t duration  -i  original.ogg  clip.ogg

Here you have to give duration of video. ie. 00:25:33-00:09:23

| improve this answer | |
  • 1
    As I mentioned on the other answer: With your command, you're re-encoding the file, which is absolutely not necessary and results in reduced quality and increased processing time. – slhck Jan 11 '12 at 21:18

I use the following syntax to cut video with ffmpef:

ffmpeg -sameq -ss [start_seconds] -t [duration_seconds] -i [input_file] [outputfile]

-t is used to set the duration in seconds - you can't specify the end time but this should work for you.

| improve this answer | |
  • 1
    Why are you setting FFmpeg to re-encode the file? Note that -sameq does not mean "same quality" at all. – slhck Jan 11 '12 at 21:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.